Insert menu intermittently not working

  1. ‹ Older
  2. 2 weeks ago

    Julian S

    Oct 31 Pre-Release Testers, Xojo Pro UK

    Happened again.

    I'm going to get to the bottom of this soon.

  3. Joost R

    Oct 31 Pre-Release Testers, Xojo Pro The Netherlands

    According to my knowledge, this is not a 2018R3 problem but is there for some versions already.

  4. Wayne G

    Nov 1 Pre-Release Testers, Xojo Pro New Zealand axisdirect.nz

    I have not seen this issue, but then my projects are probably a bit simple. I do not have any plugins other than those delivered with Xojo.

    I do find that after a period of time File->Open Recent will appear to work but does not load a new project. However performing the same function from the system tray icon will work. This is a sure indicator to me that Xojo is becoming screwed and will fail - so I reload the IDE.

    Unlike others, I will often run the IDE for many days before reloading (triggered by the failure mentioned above).

    Obvious questions are - What plugins do you have installed? Does this issue happen without any non-Xojo plugins? And can the issue be replicated in a way that Xojo can investigate?

    As we all know reproducible issues are worth their weight in gold. Create a feedback case & attach your project.

  5. Joost R

    Nov 1 Pre-Release Testers, Xojo Pro The Netherlands

    It definitely makes a difference having more or less plugins loaded.
    I normally try to limit the usage of third party plugins, but there are situations you just can't.

  6. Julian S

    Nov 1 Pre-Release Testers, Xojo Pro UK
    Edited 2 weeks ago

    @Joost R According to my knowledge, this is not a 2018R3 problem but is there for some versions already.

    Yeah it was happening before 2018r3.

    @Wayne G I do find that after a period of time File->Open Recent will appear to work but does not load a new project.

    That'll be the problem, File>Open fails as well as Insert>... and some more menus. So if you're running no plugins then that rules out plugins.

    I don't think its project related as it happens in such a wide variety of projects for me, it feels more actions over time related, but who knows.

    I'd be interested in a 32bit build to see if its happening with that. Feedback search is offline again so I can't look back to see if there are any reports of it before 2017r3 and my brain loses accuracy over time on things like this.

  7. Julian S

    Nov 1 Pre-Release Testers, Xojo Pro UK

    Happened again.

  8. Wayne G

    Nov 1 Pre-Release Testers, Xojo Pro New Zealand axisdirect.nz

    @Julian S I don't think its project related as it happens in such a wide variety of projects for me

    Me too.

    I'm getting the feeling that I'm not experiencing most of the speed/function issues the way you & @Joost R are is due to the way I use the IDE. @Joost R mentioned in https://forum.xojo.com/50885-typing-speed-weird-discovery/p1#p412502 using bookmarks could be an issue - I don't use bookmarks and possibly more important I close that bottom pane (Search/Errors/Messages) to conserve desktop real-estate.

    Have a great weekend people!

  9. Joost R

    Nov 1 Pre-Release Testers, Xojo Pro The Netherlands

    @Wayne G I don't use bookmarks and possibly more important I close that bottom pane

    Neither does my friend and PRO-developer, he's also not facing these issues.
    But why do we have these nice and very useful features since it seems we cannot use them in big projects ?

  10. last week

    Julian S

    Nov 4 Pre-Release Testers, Xojo Pro UK

    Happened again.

    I added this to the ticket:

    This time I had DebugView running and I got the following information.

    When a working menu is pressed I see the following in DebugView:

    Command "Library" handled by First Responder handled command

    However when I click a menu that isnt working like Insert>Module or Windows>Next Tab I don't see that message.

  11. 6 days ago

    Julian S

    Nov 7 Pre-Release Testers, Xojo Pro UK

    Happened again.

  12. Julian S

    Nov 7 Pre-Release Testers, Xojo Pro UK

    Happened again. >:(

  13. 5 days ago

    Julian S

    Nov 8 Pre-Release Testers, Xojo Pro UK

    Happened again.

  14. Beatrix W

    Nov 8 Pre-Release Testers Europe (Germany)

    I seem to have the problem that Cmd-R doesn't work anymore when I'm working in the debugger. macOS 10.13, Xojo 2018r3.

  15. Julian S

    Nov 8 Pre-Release Testers, Xojo Pro UK

    Have you checked the shortcut still exists in the shortcut editor in Edit>Options>General>Edit button?

  16. Beatrix W

    Nov 8 Pre-Release Testers Europe (Germany)

    Well, I usually start debugging by doing a Cmd-R.

  17. Julian S

    Nov 8 Pre-Release Testers, Xojo Pro UK

    Has it ever worked in 2018r3 or is it intermittent? Did you see if the entry was in the shortcut editor still?

  18. Beatrix W

    Nov 8 Pre-Release Testers Europe (Germany)

    Intermittent. What else?

  19. Julian S

    Nov 8 Pre-Release Testers, Xojo Pro UK

    @Beatrix W Intermittent. What else?

    I don't know, "doesn't work any more" says to me it doesn't work any more, not that it works sometimes, you just said it doesn't work any more, so I was trying to gather some more info for clarity :) Like I've asked twice now if the entry is in the menu editor and you haven't answered :D

    I can't really help with that one as I've not come across it, there's some mac tools out there for screen recording as you work, when something happens you can trigger a recording of the last x minutes, I'm sure someone can post some links. Getting a video of it happening sure would help to narrow that one down.

    It might be best to make another thread about it or a feedback ticket with some additional info, like when it happens does the Run button work or the menu option for run or does it vanished from the menu editor and see if others are experiencing a similar issue.

  20. 4 days ago

    Julian S

    Nov 9 Pre-Release Testers, Xojo Pro UK

    Happened again, I'm starting to see a pattern here, I knew I wasn't mad posting in here all the time ;)

  21. 2 days ago

    Julian S

    Nov 10 Pre-Release Testers, Xojo Pro UK

    Happened again. I'm wondering if this is something to do with coming back to the PC after the screens have powered down or its been in sleep/hibernation, clutching at straws there. If I remember I'll open all editions before I go to sleep tonight and see which if any break as I had a 2016r3 open that didn't but the 2018r3 did. Hmmm

or Sign Up to reply!