Language settings of OS not taken into account

  1. 2 months ago

    Payam A

    Oct 8 Pre-Release Testers, Xojo Pro

    Hi,

    With Xojo 2017.2.1 the application displays the date format in English, although the Regional and Language Settings on Mac are set to French. This happens since I installed Mojave.

    Thanks,
    Payam

    I just tested Mojave and it seems to be fine in 2018r2. Perhaps you should try running your project in a newer version of Xojo.

  2. Greg O

    Oct 9 Xojo Inc

    In the Language & Region system preference, Is French listed as the first language in that list? If so, click on the Advanced button at the bottom. Are the Date settings correct in there?

  3. Payam A

    Oct 9 Pre-Release Testers, Xojo Pro

    Hi,

    Thanks for your reply. Yes French is listed as first language and in Advanced the date settings are in French. If I test in other applications such as Pages, the date displays in French. But this is not the case with my app made with Xojo. As already stated, this problem appears only in Mojave.

  4. Greg O

    Oct 9 Xojo Inc Answer

    I just tested Mojave and it seems to be fine in 2018r2. Perhaps you should try running your project in a newer version of Xojo.

or Sign Up to reply!