Xojo 2018r1 Internal Server Error

  1. 11 months ago

    Alexandre C

    23 Apr 2018 Pre-Release Testers, Xojo Pro Brazil

    Hi!

    I compiled a simple application with new 2018r1 and uploaded to my server as i allways do.

    I can't run the cgi.

    (my previous compiled version 2017r3 was just fine)

    Do i need to update or change anything on server?

    Best regards,

    Alex

  2. Marius D

    23 Apr 2018 Pre-Release Testers Herford, Germany

    Nobody knows, without some information...

    Are there some error-log from the webserver?

    If you have an shell on that server, try to run the app directly from shell (you can do that with the CGI-Version) to see if you get en error.

  3. Alexandre C

    23 Apr 2018 Pre-Release Testers, Xojo Pro Brazil

    /home/caffot/public_html/cgi-bin/cadastroCAF/cadastroCAF: error while loading shared libraries: libunwind.so.8: cannot open shared object file: No such file or directory
    Use of uninitialized value $ENV{"REQUEST_METHOD"} in string eq at ./cadastrocaf.cgi line 110.
    Can't use an undefined value as a symbol reference at ./cadastrocaf.cgi line 118.

  4. Marius D

    23 Apr 2018 Pre-Release Testers Herford, Germany

    you have to install libunwind8:

    apt-get install libunwind8

  5. Marius D

    23 Apr 2018 Pre-Release Testers Herford, Germany

    Web-App doesn't start after updating to 2018-R1

  6. Alexandre C

    23 Apr 2018 Pre-Release Testers, Xojo Pro Brazil

    Hi!

    The library "libunwind8" is not available in the Centos (v7.4) repo.
    The one available here is "libunwind" only.
    ---
    root@host [~]# yum search libunwind
    libunwind-devel.i686 : Development package for libunwind
    libunwind-devel.x86_64 : Development package for libunwind
    libunwind.i686 : An unwinding library
    libunwind.x86_64 : An unwinding library
    ---

    can i install libunwind?

  7. Daniel W

    23 Apr 2018 Australia

    I was able to install libunwind.so.8 on centos 7 but it didn't seem to resolve the dependency.

    yum install -y libunwind.so.8
  8. Daniel W

    23 Apr 2018 Australia
    Edited 11 months ago

    @Marius Dnbsp;Noetzel
    Web-App doesn't start after updating to 2018-R1

    Link doesn't work.

    Page Not Found
    For some reason this conversation cannot be viewed. It may not exist, or you may not have permission to view 
  9. Alexandre C

    24 Apr 2018 Pre-Release Testers, Xojo Pro Brazil

    The library "libunwind8" is not available in the Centos (v7.4) repo.
    The one available here is "libunwind" only.
    ---
    root@host [~]# yum search libunwind
    libunwind-devel.i686 : Development package for libunwind
    libunwind-devel.x86_64 : Development package for libunwind
    libunwind.i686 : An unwinding library
    libunwind.x86_64 : An unwinding library
    ---

    should i install libunwind?

  10. Greg O

    24 Apr 2018 Xojo Inc

    @Alexandre C The library "libunwind8" is not available in the Centos (v7.4) repo.
    The one available here is "libunwind" only.
    ---
    root@host [~]# yum search libunwind
    libunwind-devel.i686 : Development package for libunwind
    libunwind-devel.x86_64 : Development package for libunwind
    libunwind.i686 : An unwinding library
    libunwind.x86_64 : An unwinding library
    ---

    should i install libunwind?

    Yes.

  11. Alberto D

    24 Apr 2018 Pre-Release Testers, Xojo Pro

    @Daniel W Link doesn't work.
    Page Not Found For some reason this conversation cannot be viewed. It may not exist, or you may not have permission to view

    The link is available to users with a Pro license only. It is a special forum area.

  12. Daniel W

    25 Apr 2018 Australia

    I can confirm that yum install -y libunwind.x84_64 resolved the dependency for me.

  13. 9 months ago

    José L

    27 Jun 2018 Pre-Release Testers, Xojo Pro

    I have the same problem with a Linux Debian 7 (Wheezy). I can't install libunwind8 with apt-get install. I have to go to a previous version of Xojo to solve this problem.

  14. Marius D

    27 Jun 2018 Pre-Release Testers Herford, Germany

    @JoséLuis ;Cuesta I have the same problem with a Linux Debian 7 (Wheezy). I can't install libunwind8 with apt-get install.

    Wheezy has only libunwind7 so you can't install version 8, try 7

or Sign Up to reply!