Xojotest web app not properly running

I’m trying to test out the Xojotest sample web app on my server just to get started with Xojo web development. It’s not properly running, saying:

[quote]Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

More information about this error may be available in the server error log.[/quote]

The server logs say:

I’ve set up CGI access/permissions and I’m using the Linux CGI app directly from:

I’ve also made and built a simple app and uploaded it to the server and it’s getting the same error.

Not sure if you tried this… are you uploading to the cgi-bin directory? As for the internal error I remember getting that and it was due to permission sets. 755 for everything but the config which is 644 seemed to fix my issues with internal server error.

Also something to note- sounds like you have uploaded 2 different apps just make sure you give them new app identifiers under the shared section under build. Each app needs new identifiers otherwise you’ll get the famous - can’t open on port xxx.

Thanks, it was basically related to the permissions in the cgi-bin itself. Appreciate the info!