Xojo2018r1-XojoConsoleFramework64.dll crashes when using 64-bit debugger on web apps

OS Development Platform Info: Win7 Pro Ultimate 64-bit (not a VM)

After successfully installing the latest version of Xojo, 2018r1, I am unable to get the 64-bit debugger to work without XojoConsoleFramework64.dll crashing. The 32-bit debugger works just fine. The 64-bit debugger will launch and execute the web app all the way thru the app.open event but as soon as it launches the browser and tries to start a session, XojoConsoleFramework64.dll crashes with the following information:

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	DebugWebFootballPool.exe
  Application Version:
  Application Timestamp:	00000000
  Fault Module Name:	XojoConsoleFramework64.dll
  Fault Module Version:
  Fault Module Timestamp:	5ad62ed8
  Exception Code:	c0000005
  Exception Offset:	00000000000a3886
  OS Version:	6.1.7601.
  Locale ID:	1033
  Additional Information 1:	3b1c
  Additional Information 2:	3b1c81e7d4b4b7bf17d20c6777f3217e
  Additional Information 3:	2ac8
  Additional Information 4:	2ac86363f53cb2771eb0211ddf0896ab

It never makes it to open event of the initial web page or any open event of any of the controls on the initial web page. It doesn’t even make it to the open event for the session. This only occurs when trying to “Run” the 64-bit debugger on any pre-existing web application. If I start a new web application, the 64-bit debugger works just fine. For the record, I have tried to get 64-bit debugging of pre-existing web apps to work having both IE11 and Firefox 59 as the default browser. That doesn’t make a difference. I still get the same crash right before it establishes the session. Again, 32-bit debugging in 2018r1 is working fine with my pre-existing web apps.

One odd thing that I have noticed is that when opening applications in newer versions of Xojo, I usually get a notification saying that the app being opened was created with an older version… I don’t get that message when opening any of my applications in 2018r1. I also noticed that if a save a pre-existing app in the new version and compare the code, the app saved with 2018r1, has added CueText properties where there were none, modified several Styles from -1 to 0, and many (if not all) property values have quotation marks around them when they didn’t in the previous version. I don’t know if any of this is related to why XojoConsoleFramework64.dll would crash when using the 64-bit debugger, but a couple of those changes seem a bit odd given that all I did was a “SaveAs” and compare the 2 folder structures.

One last observation, if I do a “Run Paused” the 64-bit debugging session runs just fine. I only have an issue when trying to initiate the 64-bit debugging session using “Run”.

Has anyone else had any issues getting the 64-bit debugger to work on a pre-existing web app, on a Windows 7 machine – other than the issue with the breakpoints of course? Does the 64-bit debugger have any sort of new prerequisites or requirements in order to run successfully? If anyone else has experienced the same issue, have you found any way to get it to work?