Xojo Web App on a Mac Running FileMaker Server 14

Anyone here running FileMaker Server 14? If so could you try building a web app and see if you can access it via the internet?

I’ve run Xojo Web Apps in the past on a Mac running FileMaker 13 Server in the past with no issues, but recently we updated to FileMaker 14 Server. The server is colocated and I can screen share into it. When the server was running FileMaker Server 13, we’d access the Xojo Web App using the static IP address via port 2500. Now when we try to access the Xojo Web app using the the URL, it won’t load. If I remote control the Mac, the Xojo Web App comes up immediately using I also tried the exact same Xojo Web App on another Mac running FileMaker Server 13 and it works as expected.

The built in Mac Firewall is off on both Macs and there’s no other blocking software.

Any ideas what the problem could be?

Hello Hal,

The list of default Ports used by FileMaker Server 2014 differ in several instances (not many) from those used by FileMaker Server 2013.

Ports used by FileMaker 2014
Ports used by FileMaker 2013

Neither list contains port 2500, however that doesn’t prove the port is listening for requests or can establish connections.

Make sure the web app is running, then in a terminal window, try: netstat -ap tcp to check whether port 2500 has an established connection (state=established, or perhaps state=listen). For windows, just run netstat at the cmd prompt.

Extract from my cmd prompt.
Proto Local Address Foreign Address State PID

the foreign address in my case being the xojo web app opened in my web browser on my local machine.

Whilst not the complete answer, it may help you troubleshoot a little more.

Kind regards, Andrew

Thanks Andrew.

I ran netstat -ap tcp and there were no entries for 2500. To be sure I pasted the results into TextWrangler and searched for 2500.

The Xojo Web App is accessible at on the machine. When I try my staticIP:2500, it won’t load. FileMaker seems to be running normally. Same is true when I try port 55555.

Oh. I’m running the Xojo Web App as a Standalone app…

The only way I can imagine this is if a firewall is in place. As by default a web app will listen in all interfaces and that is the only way to get it to listen on localhost, the requests must be getting blocked somehow.

Is it possible that the installation of FileMaker 14 also installed another firewall program?

FileMaker install/configures its own web server. So this may conflict with the ports.

I thought about the FileMaker Ports too, Christian. From the tech docs, it doesn’t list ports 2500 or 55555. It works locally in Safari.

Tonight, I’ll stop FileMaker Server and see what happens.

Those ports should be free.
But even if FMS is not running, it the web server will use 80 and 443 for web server to show admin user interface.

But maybe a firewall blocks you?

The Mac internal Firewall is off. I installed no other firewall. I also am running CrushFTP so I disabled it with no success.

Tonight, I’ll stop FileMaker Server and test again. If that makes no difference, I’ll update the FileMaker 13 Server where Xojo Web Apps run fine to 14 and see if it breaks.

Thanks for all the input on this! :slight_smile:

Hal, I have OS X Server 10.10.5 with FileMaker Server 14 (running WebDirect) and am also able to run multiple Xojo web apps (standalone) just fine. I’m using ports in the 8xxx range, but I don’t see any difference between that and port 2500 (ports below 1024 require admin permissions in *nix systems).