Xojo Web 1.0 build fails on Big Sur

I maintain a project that includes an internal web app which currently still runs as Web 1, so I compile this in Xojo 2019r1.1.
The main project is converted to Xojo 2020r1.2 (API 2.0) already.
This used to work until I installed Big Sur.
Now for the macOS build I run into this error

Linking Executable
ld: file not found: /System/Library/PrivateFrameworks/UIFoundation.framework/Versions/A/UIFoundation for architecture x86_64

Could this be connected to Big Sur? Or a different bug?

You have a web app with a declare to UIFoundation?

1 Like

I am using TPSF to easily locate the database. The web app runs on localhost. The whole project is a training software for business schools. The web app is a web shop simulation so each student can be his own client on his personal training computer running a local Webshop. The build is for macOS and Windows.

But thanks! Could be connected to TPSF! But why does the main desktop project still compile then? It is converted to API 2.0 but still uses TPSF.

See the release notes for 2019r3.2

60739 Build Fixed linker error that occurred on macOS Big Sur.

In other words: You’ll need Xojo 2019r3.2 to be able to build (for TargetMacOS) on macOS 11.

1 Like

Thanks, Jürg!
Sigh – that means I have to adapt the Web project to API 2.0 slightly. I hoped to avoid that for some more time.
But a solution. Thanks a lot!

Can’t you still use API 1.0 for web projects in 2019r3.2 without any adjustments?

Not fully in this case. I run into a few locale problems.