Xojo version compatibility w/ OSX version

I’ve been using Xojo 2018 1.1 on my OSX 10.11.6 system (El Capitan)
I just bought another 2015 Mac which has 11.5.2 installed (ie Big Sur)
I was trying to run Xojo 2018 1.1 and had some issues with one particular Xojo binary project. I tried bringing all the objects into a new project etc. Still had problem, it would not launch the application. Now it compiles and runs, but it gets an error where it says a Picture object is Nil when I try to use Picture.Graphics. But if I test that Picture for Nil (ie If pic = Nil) that test fails (ie the object pointer was not Nil on the line before the code fails).

So I tried the most recent version that would work with my licenses. That was 2019 3.1. When I try running the project I get a different error:

Linking Executable
ld: file not found: /System/Library/PrivateFrameworks/UIFoundation.framework/Versions/A/UIFoundation for architecture x86_64


You need 2019r3.2
If your license allow 3.1 it should allow 3.2

Thanks Alberto
OK so I tried 3.2…and it does compile and run.

But the error is still occurring, as it did with 2018 1.1
At this point it seems the Picture object has no Graphics object.
This code worked on the other system.
Also I can see the Picture contents when debugging. So the Picture object has loaded the file apparently.

OK I see. Having loaded the Picture, there is no Graphics object…its Nil. The depth is 0. But there is an RGBSurface. And I can see the image in Contents.

So my problem seems to be some more detailed gotcha related to bitmaps, that did not apply on the earlier OS version.

Yep that was it. That Graphics doesn’t seem to work on this OS version whereas RGBSurface is good.