Xojo Version and Windows Update Status

I have an in-house am I originally wrote a few years back, that I am in the process of updating. When I tried to deploy the updated version on a lab PC running Windows 7 Service pack 1, using Xojo 2014r3.2, I started getting weird behaviors… Text would not show up in one listbox, and I would get Nil object crashes I did not on other PCs.

When I recompiled with Xojo 2013r3.3 (needed to for some Mac Running 10.6 anyway) that worked perfectly. Then I checked Windows update… The last time Windows update on that system was sept 2011… Which is about when that machine was put into service…

So Is this a bug with the new version, or are specific updates now required for Windows 7… I believe Xojo is supposed to support back to Vista so the I did not realize this could be an issue.

  • Karen

Sounds like your windows 7 or your code is broken somehow. My Xojo programs runs from WinXP SP2 to even to Win10 Preview without hassle

It supports built apps all the way back to XP. And like Tomas I recently ran an app in the Windows 10 preview just to make sure it ran.

I would do all the updates on the machine that’s having the problem, first, and then see if the app is exhibiting strange behaviors.

the weird thing was the same code compiled with 2013r3.3 worked , while when compiled with 2014r3.2 it did not…

I am having someone try and update that machine.


  • Karen

Yeah, that is weird, but I’d still vote for getting the machine updated. It’ll probably take all day though. I’ll guess over 250 updates. :slight_smile: