Xojo Plugin Compilation: Got an XCode Error

Hi,

I just downloaded the TextInputCanvas to update it to API 2.0. Xojo thinks that we users can do this on our own and we shouldn’t wait for them (Geoff himself said it in a feedback case).
Now I have opened the file “TextInputCanvas.xcodeproj” in Xcode and can’t compile the project. There is one single error. This one is:

What exactly do I need to set in XCode to compile the project? I don’t work with XCode, so I don’t know what to do. I work under macOS 10.15.2 with Xcode version 11.3.1.

Thank you very much.

feedback://showreport?report_id=53851
feedback://showreport?report_id=51115

and I think Christian still builds it as one of the free parts of MBS

You can disable the weak option in compiler settings.

We do have a compiled copy from last year to download on our website: TextInputCanvas.dmg

[quote=473168:@Christian Schmitz]You can disable the weak option in compiler settings.

We do have a compiled copy from last year to download on our website: TextInputCanvas.dmg[/quote]
Thanks Christian, I know, but I wanted to update it to API 2.0. Especially those methods in TextInputCanvas.cpp:

Line 77: CharacterAtPoint(x As Doube, y As Double) As Integer ' instead of Integer Line 87: Paint( g As Graphics, areas() As Xojo.Rect ) ' instead of areas() As object Line 88: RectForRange(ByRef range As TextRange) As Xojo.Rect ' instead of REALBasic.Rect
Could you please update it for us? Create an API 2.0 Version? I would be very happy, since you have included support for GTK-2/GTK-3 in your version for Linux. This would be helpful. Thanks.

this really should be an officially supported control and Xojo should update this

Geoff Perlman wrote (feedback://showreport?report_id=58957)

Given that TextInputCanvas is used by the IDE and users need it in order to make a compliant text editing component Xojo should update it

Well, I doubt Xojo is using the new API much in the IDE yet. So it doesn’t affect them (yet).