Xojo mysteries…

In a method used to save data I get an IOException (IOE) here:

SaveBS = BinaryStream.Create(SaveFI, True)

I do not recall if the crash occured in TEXT AND CSV saves or in CSV save only. I do not checked drag and drop too, nor Copy / Paste…

SaveFI is checked against Nil before that method is called !

I saved a screen shot that displayed the IOE and the code error (-1704 ?), but where is that file now ?

Not a problem, I just have to re-run the application and re-do the screen shot !

Fortunately / Unfortunately, now the application does not have the IOE error !

Prior now, I made a shutdown/reboot (and no nothing in between) process at personnal clean up time in the bathroom, then after a break of some minutes, I re boot the MacBook Pro, run Xojo / load the project, run it and the crash was still there. I generate the stand alone and fire it to discover the crash again.

Excepted for the first crash, all successive were only tests and I do not loose any data (excepted in the first crash and they were only column additions and Header name changes [more or less]).

Only difference: internet active now.

OS X El Capitan
Xojo 2015r1
Both are fresh install from last week.

You need to put in a Try/Catch and catch the IOException, and check it’s message and error number.
Until then there’s nothing that can be done.

If you exception error was (I believe) a 104, then it more than like means

  1. the specified file location DOE exist as you suspect
  2. HOWEVER, some other application has the file open, and therefore is denying access to it.

I ran across this hundreds of times while testing my PDF Class.

I would run a test,
Open the PDF file in Preview mode to see if it did what I wanted
Alter the code
Run it again, and it would fail (error 104), because Preview still had the file open.
Shut down Preview, and it ran just fine.

First: thank you for your answers.
@Tim: you are right.
@Dave: You also are right, but the only owner of the file is that application and this is an Export feature *, I changed the file name to avoid destroying a previous version with a bad new version and lost data…
The file have been generated by this application saved as .txt, then loaded, modified, and saved as csv.

Second: I didn’t work on Xojo yesterday, so I do not recall what I’ve done the day before yesterday.

Three: I think that the “trouble” disappears as it comes… and I was able to run back a newly build stand alone; i have to check that.

Four ? When I have to face this kind of troubles, my anger comes all of a sudden and I have hard time to go back to a standard way of working (taking snapshote, recalling what I’ve done before the crash, etc.). Also, I have a hard time to explain things. Sorry about that.

BTW: I am Cool, Calm and try to Collect data slowly in order to be understand. No rant exist in this answer. (just in case of a wrong reading if my writing is not that cool).

Note: there is a contagion bug in OS X that exists since 10.2 / 10.3 (or 10.3 / 10.4) that affect the whole lot of mass storage hardware at eject time. When I had to change (replace) my PowerBook, I used it during a day or two before connecting (I do not tell sync old contents to new hardware: I only connect an external Hard Disk) an external Hard Disk and at the next boot, the infection growed. Same apply for my other 3 laptops (this one included). When, last week or so, I cleared the internal SSD and installed El Capitan, it worked fine a whole day with many reboots, until the next day I connected my all purpose external HD: the contagion resumed.
At last, I installed the last El Capitan beta minutes ago. In a Finder window in list view, I double clicked into the header separator between the name column and column 2 and it get resized to display all file names in that column. I closed the window, re-open it, re-click in the very same separator in the header and it does not works anymore !
Yes, this is an Apple problem, but this may interfere with the Xojo IDE…
Since the last El Capitan installation, my all purpose external HD activity LED nearly never shut down… Go figure !

are you sure your app is executing a file .CLOSE on the Text/Binary Stream (which I assume is how you are writing the file)?

Executing ? I do not know (?), but I wrote one before the code ends (in the method).

Previously I lso add:

TextRefTIS = Nil

TextRefTOS = Nil

And I understand this is not needed / may lead into error, so I removed them… all of them.