Xojo License Problem

Last week I deauthorized the Xojo Pro license on my laptop. Today I used the laptop and opened an app that had been saved as a xojo_project. When I tried to save it, I got an error message saying I didn’t have the proper license to save as a text file (or something to that effect). Neither of the two buttons offered (Cancel or Buy a License, I think) worked and I had to use Windows Task Manager to kill Xojo.

I went to the Xojo website and deauthorized one of the three Pro licenses. In Xojo 2023r4, I went to Help | License Keys | Update only to get a message “Your account has no current license keys”. I rebooted, deauthorized another license and tried again. Got the same message again. Deauthorized the last active license and still have no current license keys.

Everything worked fine last week before I deauthorized this machine. I didn’t expect that I was deauthorizing it forever. We have several computers at work with each running a different app. Most of them are controlling attached hardware so I need to make updates on that machine. Switching licenses before was a hassle. Now it has become impossible.

Did you go to your account and delete the activations?

Yes, I deleted all the activations for the Pro version.

Just now, I downloaded the license again and tried to install it. It says the license key is not valid for this version and is only valid for versions released before 11/29/22. That is the expiration for a Web only license I had. My current Pro license expires 5/24/24. I used the same email address for both licenses.

You could try logging out and back in to the account in Xojo. Also would be worth emailing hello@xojo.com with such problems.