Xojo iOS Xcode 8 building error

My coworker upgraded his OS to Sierra, so the xcode 6 crashes on his computer. He installed the xcode 8 but gets an error while building an iOS app.
“The operation could not be completed. path/to/app.app:resource fork, Finder information, or similar detritus not allowed.”
If i remove the attributes from the files with terminal command then I cant install the app to the ios device.
If i remove the attributes from the project files, and build it, then the error pops up again.

I tried to install xcode 7, 7.3 too, same error message.
We were using x6 becase we have xojo 2015r2.4

Which version of Xojo are you trying?

You can’t use Xcode 8 with Xojo 2015r2.4- it was released well before any of the big changes Apple made recently. You need to either rollback to an older OS X and an older Xcode, or update to the current release of Xojo (2016r4) which supports the changes Apple made with Xcode 8.

This is a blanket covering for the various types of attributes added to the files by the Finder and other programs.

Some of it can be removed with the terminal command xattr -xc <filePath/>. Some of the other things can cause this issue, are a little more complicated to ‘clean’. I spent a lot of time figuring these out for App Wrapper and my customers who were plagued by these changes, but sadly it won’t help you with iOS applications.

Basically this the code sign functions with Xcode 8 on Sierra, the safest way (and the route that even iOS developers who use Xcode) has taken is to revert back to El Captian for development.