xojo image not included in build and deployment

Hi Master!

I am able to deploy my sample application to my IIS server.
But I noticed that the image is not included from the build folder.

Please help on how to include the image to the build folder so that I can upload it to my server.

In 2016r2 They should be in the Resources folder next to the app. Before that they are embedded in the app itself.

Hi Greg!

Right now im using 2016r1.1, so how about this version?

if you’re talking about pictures dragged into your project, they’ll be embedded in the binary. If they are in a folder next to the app, use a CopyFilesStep to include them.

Thanks for answering Greg.

I just drag the PNG file (logo) to my xojo web app. It shows when I run it on my development PC.
After build, I copied all files and folders from the build folder and upload to my web server. When I run it from the browser, it doesn’t show the logo.

I hope you can help me resolve my trouble. I really appreciate it.

Please try another png first. I don’t remember seeing this before.

Thanks again Greg.

i tried to use small png but the result is the same. I posted the screenshot to give you more idea on my problem.

Calling also some other Master XOJO to help me. Please…

Are you able to reproduce this problem in a small sample app?

Also, are you displaying the image with a WebImageView? Could you show us some code?

Thinking about this further, one way this could happen is if the underlying WebPicture were to go out of scope by the time the browser requested it. That’s why I’d like to see a sample of your code.

Hi Greg!

I just drag the webiimageview on the webform, from the properties, I select the PNG file .

Here is my actual xojo code:

link text

I hope you can give me idea on how to fix this


Ok. first of all, you can’t use these URLs from one run to the next. The identifier (3295-3751-6486-5088-8674) in this url:


will not persist from run to run. Any url that begins with an underscore (_files in this case) is reserved by the framework and should not be accessed directly as text as it will probably change from run to run.

Instead, try doing it this way:

ImageView2.Picture = logo_word

I would also suggest that if you want it to show up immediately, you should assign this value in the IDE by selecting the image in the Picture property popup menu on the inspector.

Hi Greg!

I finally found the solution!

I drag the picture within the BUILD settings and click then rebuild!

I noticed that I still need to include the physical PNG file within the BUILD SETTING to make it work.

Thank for the effort Greg, I really appreciate your responses.