Xojo hanging during 'compiling' stage of Build - Mac and Win

I have a long term xojo project (pre 2015) that started as a Web 2.0 project but I’ve converted to new Web 3.0.
Last year (under 2022R2) it was compiling - but today I updated to Xojo 2022R4.1) and after selecting Build, it is hanging during the ‘compiling’ step.
Using top, I can see the compile initially starts about 8 ‘HoudiniAssistant’ processes but after a few seconds all but one of these end. The last one remains, is using ~100% cpu and I’ve left for over an hour with no effect.
If I run the project, it runs fine. Only when I attempt to build that it gets stuck.
If I kill the ‘HoudiniAssistant’ - Xojo reports error 15 - Linking Executable

I’ve also installed 2022R4.1 on a Windows machine and same issue. It will run, but will not build.
Have selected to build for Mac only and also for Windows Only.
Have restarted my Mac.

I’m currently trying and it’s been running for over 28 minutes of CPU time as I write this.
A copy on Windows has been going for over 20 minutes.
When running the project, it takes < 30 seconds to compile and run.
I’ve downloaded and reinstalled 2022R2 - but it won’t compile.

There are no plugins used - and I’ve also removed all the default plugins.

Any ideas ?

Look at the optimization setting in shared build settings. If it’s set to moderate or aggressive, they could cause this behavior.

Also, I’ve noticed that some of the malware monitoring tools on macOS cause this issue as well.

1 Like

Hi Greg,

I’m trying on both Mac and Windows - both exhibiting the same behaviour. I only have the default MacOS security tools - no third party ones installed.

Optimisation level was set to “Aggressive”. Changing to Moderate or Default resolved the issue.

Thanks for pointing this out - at least it’s working now.


FWIW, it would have eventually finished, but Aggressive can take a very long time to finish the last leg.

I figured that would be the case once you explained the optimisation options - but two hours and still compiling a project that takes ~10 seconds using Default optimisation. (I been out and played a game of Ten Pin Bowling with the family, had a bite to eat, then home again).


Well it’s certainly possible that you’ve found a situation that the compile flags can’t handle.

FYI case #69100

Even a blank Web project fails to compile in Aggressive.

Thanks @AlbertoD, good to know that it’s not something I’ve done (other than apparently fiddle with the compiler optimisation levels last time I opened the project and caused myself a whole lot of grief in the process a couple of months later).

Thanks @Greg_O for you quick assistance - at least it was only a few hours I wasted trying to resolve this. I was about to start pulling things apart in an effort to resolve, so thankful it was a simple change in the end.

1 Like