Xojo doesn't start anymore

I had and have problems with decimals under Centos6 Linux.
I changed language into “nl_BE.UTF-8”
dim m as string = Format(“5.35”,“0.00”)
should result in : 5,35
But it doesn’t. In Win7 the result is correct.
So I changed to kde where there is a possibility to set regional settings, and changed it to Belgian, which Gnome didn’t do.

I did a update of Centos and …

Xojo2016r4.1 starts BUT when it opens an application it tells me:
libocci.so.10.1: cannot open
[RB] Unable to load plugin OraclePlugin.xojo_plugin
RBLibrary.CheckForPluginChanges 1 - needsToRecompile = true

Everything worked before with the same version of Xojo.

Do you need OraclePlugin ?
you can move it from Plugins folder. I use a folder ‘disabledPlugins’

Less plugins = faster IDE

I removed the plugin and now he doesn’t give an error. He just does nothing.

open terminal and start if from the terminal
you should get a log as it tries to start and that may tell you why

I use several versions on Centos 6 and have no issues BUT I am not running Belgian for my locale (but I cant imagine that would make it not start)

I removed the plugin and now he doesn’t give an error. He just does nothing .

I had no issues on this version of Centos6 until I switched to kde(coming from Gnome) and I changed the regional settings.
But I don’t think that is the problem. I installed Firefox and did a update of 250 items. Probably there the problem started.

That’s the result

[quote]bash-4.1$ /opt/xojo/xojo2016r4.1/Xojo xCurrencyTest.xojo_binary_project
Which means ‘NO result’

I think the path is wrong

/opt/xojo/xojo2016r4.1/Xojo /path/to/xCurrencyTest.xojo_binary_project

just start Xojo … never mind the project initially


I think we are looking in the wrong direction.
Initially the app started like

/opt/xojo/xojo2016r4.1/Xojo     xCurrencyTest.xojo_binary_project

When I do /opt/xojo/xojo2016r4.1/Xojo and then open xCurrencyTest.xojo_binary_project I have the same result, None.

So it has probably something to do with the update of Centos.
But HOW can I trace the error or the missing whatever thing…

well IF it were a missing dependency or library then trying to run would say so

best you might do is run ldd on Xojo etc and see if that finds any missing dependencies

I dont expect this will show anything (as that should be reported when you tried starting it)

but when you do try & start the IDE *via any means) does it never finish launching ?

is it set to executable etc ?

ldd /opt/xojo/xojo2016r4.1/Xojo xCurrencyTest.xojo_binary_project /opt/xojo/xojo2016r4.1/Xojo: linux-gate.so.1 => (0x00dc8000) librt.so.1 => /lib/librt.so.1 (0x00844000) libdl.so.2 => /lib/libdl.so.2 (0x007de000) libpthread.so.0 => /lib/libpthread.so.0 (0x007e5000) libc.so.6 => /lib/libc.so.6 (0x00645000) /lib/ld-linux.so.2 (0x00623000) xCurrencyTest.xojo_binary_project: ldd: waarschuwing: u hebt geen uitvoeringsrechten voor `./xCurrencyTest.xojo_binary_project' geen dynamisch uitvoerbaar bestand
The Dutch language says:
You don’t have executable rights for `./xCurrencyTest.xojo_binary_project’
This is not correct because I’m not executing this app.
I’m executing /opt/xojo/xojo2016r4.1/Xojo

# ldd /opt/xojo/xojo2016r4.1/Xojo linux-gate.so.1 => (0x00e4f000) librt.so.1 => /lib/librt.so.1 (0x00844000) libdl.so.2 => /lib/libdl.so.2 (0x007de000) libpthread.so.0 => /lib/libpthread.so.0 (0x007e5000) libc.so.6 => /lib/libc.so.6 (0x00645000) /lib/ld-linux.so.2 (0x00623000)
So no error…
Xojo can be launched without any problem
When Xojo launches the app it does nothing. Launch stop after a short while.

Try to place your project file in the user home directory

It is in the user home dir
I hope that it is clear that I’m just trying to open my project.
I’m not launching it (Ctrl B)

In other words, I cannot even edit my project.

It is midnight over here. So I’m going to sleep.
Could you guys think a little bit about this strange behavior?.
And if possible get back to this matter tomorrow?


[quote=313014:@roland brouwers][code]ldd /opt/xojo/xojo2016r4.1/Xojo xCurrencyTest.xojo_binary_project

This is not correct because I’m not executing this app.
I’m executing /opt/xojo/xojo2016r4.1/Xojo
Right but I didn’t mean for you to run ldd on the app & project
Just on the Xojo app

Ok but thats not what the title of the thread says :stuck_out_tongue:
It implies XOJO wont work

Which suggests its something about the project - not necessarily Xojo

You ARE using version control … riiight ???

Can you create a new project ?

corrupt project file ?

I tried to start a new project, but even this is not possible. He tries to start it for 3 sec and then the window ‘Choose a project’ disappears, as if I was doing nothing.

I did a
yum update
and now it works

[h]Why did I do the update?[/h]
Because decimal separator doesn’t work
The instruction

dim a As string = [b]format[/b](6.25,"0.00") TextField1.Text=a
should generate : 6,25
It does it right under Win7
but under Centos6 it generates : 6.25

It’s like
dim a as currency = [b]Cdbl/b
should generate : 25.45
But under Linux it gives 2545
under Win7 it gives 25.45

The settings of Centos6 are Belgian; 12 456,55
Konqueror shows file size like 1,2 Mb
scalc works fine


in Ubuntu (16.04, german) I get this

dim a as currency = Cdbl("25,45") fld.AppendText str(a) fld.AppendText(EndOfLine) dim b As string = format(6.25,"0.00") fld.AppendText(b)