Xojo display prefs

This may be really obvious but I can’t find it, nor can I find a forum entry on this.

I am new to working with Xojo in Windows (I usually work on a mac; we just got the windows laptop on Monday).

Everything on the Windows laptop has such tiny font! I’ve done what I can through the Windows control panel, but in Xojo, the panel on the left side (especially, but other things too) that shows all the controls and such – it has such TINY font! It is SO difficult to read! Either I have to get my head fairly far from the screen and tilt my head just so to bring it into focus through my graduated bifocals, or I have to remove my glasses and get within a few inches of the screen (thus making other parts of the screen momentarily not visible because I’m too close, plus this is just uncomfortable). HELP! is there any way to make those parts of Xojo have a bigger font? Is this a Xojo (or any app) specific thing (I am seeing smaller fonts than I’d like in other apps as well) or a Windows thing and I just haven’t figured out the right way to set these things? (I don’t want to set something system-wide that will then mess up the graphics in my actual Xojo application, of course.) (Caveat: it seems that fonts on the mac in some apps are also smaller these days, but I have in most apps very easy ways of increasing the size. In Xojo on the mac, that same panel does have pretty small font, but it is still much more readable than its analog on the PC laptop.)

Thanks from a Windows newbie, and sorry for such a basic question.

Why don’t you change the font size in the preferences/options?

What version of Windows are you using? There ought to be a Windows Control Panel setting to increase the system font size.

@Beatrix Willius : I believe I have (Edit–>Options–>Coding and -->Layout are the only things I’ve found within Xojo), and it seems to affect the actual code, but not the stuff on the (lefside. Changing the screen resolution seems to help a little, but not quite in the way I’d prefer.

@Paul: XP professional v 2002 SP3 (This is what we’ve been told to use, apparently).
I did try going through all of the control panels that appeared relevant, and have set one thing to “Large font” instead of the regular, but that seems to only affect the labels and such for particular windows; it certainly isn’t affecting the left panel of Xojo (or a lot of other things).

thanks to you both for replying.

For the moment I’m guessing I need to use the screen resolution to get a font I can comfortably read, but eventually I need to put it into the screen res the end user is going to use (don’t know that yet). Maybe I’m getting too old for the fonts of today…

Hi Carolyn,

The most stable way to have consistent fonts and proper sizing on a Windows OS system is to change the resolution. You will need to set the font and all other properties back to their default settings before modifying the resolution, otherwise the computer will likely give some unintended surprises :slight_smile:

When modifying the resolution, there are ratio’s for each resolution… Just from memory, the two common ratios are 4:3 and 16:9. If you know the factory resolution of the computer setup, then keep the ratio the same.

Resolution Ratios

As an example, lets say the original factory resolution is 2048 x 1142 (16:9 ratio). This resolution is too high for my aging eyes, and the font and program details are too small. I can change the resolution to 1280 x 720 (also a 16:9 ratio) and the fonts will be larger, there will be a nicer placement of the programs, and everything will be resized correctly.

Let me know if this is helpful :slight_smile:

Hello Carolyn,

Over the holidays, a friend of mine had a computer that resized the factory resolution did have success in all programs working correctly. However, the resized screen was slightly hazy, as you mentioned. After adjusting the resolution in a few ways, the resolution on the screen was hazy on his computer, and performing the resolution change on the GPU was as clear as the original.

He had an NVIDIA graphics card, and this was the solution:

  1. Open the NVIDIA Control Panel
  2. In the Select a Task… panel on the left side of the control panel expand the Display tree.
  3. Next, click on the Adjust desktop size and position.
  4. Select the display to change the resolution (there will be one if there is only one display)
  5. In the section Apply the following settings:, choose the Scaling tab
  6. Change the Scaling Mode to Aspect Ratio
  7. Change the Perform scaling on: option to GPU
  8. Select the lower resolution based on the screen ratio which was 16:9 in the previous post

I hope this works for you.