Xojo crash on linux Mint 19.3


I just installed Linux Mint 19.3 Cinnamon on my Acer Aspire E5-772G.
I have installed Opera as second web browser, and after that, I installed Xojo (Licensed).
I can run Xojo, but as soon as I try to use the keyboard to edit code, Xojo closes, with no error message.
I suspect this has to do with chrome, because Xojo is running fine on a Virtualbox machine, where I did’nt installa any chrome based browser.
I removed Opera, but nothing changes.
Any idea?


Hi Thierry,

Which package did you use to install Xojo? If you didn’t use the TGZ package and install into /opt/xojo/, I urge you to revisit your installation.

I just tried installing from the TGZ.
The only way to have Xojo working properly is to run it with elevated privileges.
But that not a solution!
I noticed the problem is only present on my physical PC.
Running it into a virtual machine is not a problem.
I’ll try to run it on a freshly mint 20 installed PC, and see what happens

Thanks anyway

As @Tim_Jones said use the TGZ not the RPM or DEB
There are other recent threads about the packages not installing properly on Mint 20

I thank you both for your advices.
But what i did exactly is:

  • Tried installing using the DEB package
  • Tried installing using the TGZ package. In this case, I tried installing in my home folder AND in the /opt/xojo/ folder.
    Both solution failed. Xojo starts correctly, and everything seems to be working correctly, until I try to move the cursor in the code editor USING THE ARROW KEYS. At this moment, XOJO simply closes, without any advice.

As I said, I tried installing on a virtual machine (VirtualBox) running Linux Mint 19.3, and another running Linux Mint 20. Both are running without any problem. I though it has something to deal with the fact I was running Cinnamon. I tried switching to MATE, with same result. I think the problem is linked with some driver, because they are obviously different for a virtual machine and and a physical one.

Because using a virtual machine is not really a problem, I probably will go on with that solution.

Thanks anyway for trying to help me. I really appreciate.

Could you launch Xojo from the command line and try using it? When it crashes, you should get some info posted on the terminal that will help track this down.

FWIW, I used the 2019r3.2 .deb package in Mint 20 Cinnamon last Tuesday and it installed and runs just fine. Now what I did notice is that they seem to have disabled IPv4 on the NICs though. We are looking into that.

Hi Greg.
I did as you explained.
Here is the error message I get as soon as the IDE starts: (sorry for the french message, my PC is setup in french).
libocci.so.10.1: Ne peut ouvrir le fichier d’objet partagé: Aucun fichier ou dossier de ce typeErreur de segmentation (core dumped).
If I remember well the old good days when I was at work, OCCI is Oracle related stuff.
So I can’t see a direct relationship with my problem.

Do you think there’s a way to tell XOJO to be more verbose?


Remove the oracle database plugin from the plugins folder. It’s trying to connect to a library That’s not on your machine.

I removed the Oracle plugin.
I don’t have the OCCI related error message anymore, but still have the last part
Erreur de segmentation (core dumped) (Translated : Segmentation error :smile:)

I made a test : I left the Xojo folder where it is (actually in my ~/download folder), I opened the folder as superuser, and I tried to run Xojo IDE. I have no problem, starting it with ./Xojo command or running it from the file explorer.

Sorry to bore you with this.

Not boring. Just trying to help you find a solution.

Let’s try something else. Back in the terminal, try the command ldd xojo to see if there are any other missing dependencies.


Here is what I get when typing the ldd Xojo command

linux-vdso.so.1 (0x00007ffc662bb000)
XojoGUIFramework64.so => /home/thierry/Téléchargements/xojo2019r3.2/./Xojo Libs/XojoGUIFramework64.so (0x00007f8ee1a82000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f8ee1691000)
libgtk-3.so.0 => /usr/lib/x86_64-linux-gnu/libgtk-3.so.0 (0x00007f8ee0d89000)
libgdk-3.so.0 => /usr/lib/x86_64-linux-gnu/libgdk-3.so.0 (0x00007f8ee0a93000)
libpangocairo-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpangocairo-1.0.so.0 (0x00007f8ee0886000)
libpango-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpango-1.0.so.0 (0x00007f8ee0639000)
libatk-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libatk-1.0.so.0 (0x00007f8ee0413000)
libcairo-gobject.so.2 => /usr/lib/x86_64-linux-gnu/libcairo-gobject.so.2 (0x00007f8ee020a000)
libcairo.so.2 => /usr/lib/x86_64-linux-gnu/libcairo.so.2 (0x00007f8edfeed000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgdk_pixbuf-2.0.so.0 (0x00007f8edfcc9000)
libgio-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0 (0x00007f8edf92a000)
libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f8edf6d6000)
libglib-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f8edf3bf000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f8edf087000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f8edece9000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f8edeae1000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f8ede8dd000)
libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007f8ede6db000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f8ede4bc000)
libunwind.so.8 => /usr/lib/x86_64-linux-gnu/libunwind.so.8 (0x00007f8ede2a1000)
libunwind-x86_64.so.8 => /usr/lib/x86_64-linux-gnu/libunwind-x86_64.so.8 (0x00007f8ede082000)
libc++.so.1 => /home/thierry/Téléchargements/xojo2019r3.2/./Xojo Libs/libc++.so.1 (0x00007f8eddcd1000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f8eddab9000)
/lib64/ld-linux-x86-64.so.2 (0x00007f8ee3f18000)
libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007f8edd8b5000)
libXi.so.6 => /usr/lib/x86_64-linux-gnu/libXi.so.6 (0x00007f8edd6a5000)
libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f8edd49f000)
libatk-bridge-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libatk-bridge-2.0.so.0 (0x00007f8edd26e000)
libepoxy.so.0 => /usr/lib/x86_64-linux-gnu/libepoxy.so.0 (0x00007f8edcf6d000)
libpangoft2-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0 (0x00007f8edcd57000)
libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f8edcb12000)
libXinerama.so.1 => /usr/lib/x86_64-linux-gnu/libXinerama.so.1 (0x00007f8edc90f000)
libXrandr.so.2 => /usr/lib/x86_64-linux-gnu/libXrandr.so.2 (0x00007f8edc704000)
libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007f8edc4fa000)
libXcomposite.so.1 => /usr/lib/x86_64-linux-gnu/libXcomposite.so.1 (0x00007f8edc2f7000)
libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007f8edc0f4000)
libxkbcommon.so.0 => /usr/lib/x86_64-linux-gnu/libxkbcommon.so.0 (0x00007f8edbeb5000)
libwayland-cursor.so.0 => /usr/lib/x86_64-linux-gnu/libwayland-cursor.so.0 (0x00007f8edbcad000)
libwayland-egl.so.1 => /usr/lib/x86_64-linux-gnu/libwayland-egl.so.1 (0x00007f8edbaab000)
libwayland-client.so.0 => /usr/lib/x86_64-linux-gnu/libwayland-client.so.0 (0x00007f8edb89c000)
libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f8edb68a000)
libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f8edb3d6000)
libthai.so.0 => /usr/lib/x86_64-linux-gnu/libthai.so.0 (0x00007f8edb1cd000)
libpixman-1.so.0 => /usr/lib/x86_64-linux-gnu/libpixman-1.so.0 (0x00007f8edaf28000)
libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007f8edacf6000)
libxcb-shm.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-shm.so.0 (0x00007f8edaaf3000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f8eda8cb000)
libxcb-render.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-render.so.0 (0x00007f8eda6be000)
libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f8eda4b4000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f8eda297000)
libselinux.so.1 => /lib/x86_64-linux-gnu/libselinux.so.1 (0x00007f8eda06f000)
libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f8ed9e54000)
libmount.so.1 => /lib/x86_64-linux-gnu/libmount.so.1 (0x00007f8ed9c00000)
libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f8ed99f8000)
libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f8ed9786000)
liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f8ed9560000)
libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f8ed9313000)
libatspi.so.0 => /usr/lib/x86_64-linux-gnu/libatspi.so.0 (0x00007f8ed90e3000)
libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f8ed8e45000)
libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f8ed8c13000)
libdatrie.so.1 => /usr/lib/x86_64-linux-gnu/libdatrie.so.1 (0x00007f8ed8a0c000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f8ed8808000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f8ed8602000)
libblkid.so.1 => /lib/x86_64-linux-gnu/libblkid.so.1 (0x00007f8ed83b5000)
libsystemd.so.0 => /lib/x86_64-linux-gnu/libsystemd.so.0 (0x00007f8ed8131000)
libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f8ed7f04000)
libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f8ed7cef000)
libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007f8ed7ae8000)
liblz4.so.1 => /usr/lib/x86_64-linux-gnu/liblz4.so.1 (0x00007f8ed78cc000)
libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007f8ed75b0000)
libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007f8ed739b000)

This could be the explanation. If you had run the Xojo IDE as root or via sudo the first time, you will find that the Xojo support folders are not all the property of root instead of you user.

Do this in a Terminal:

sudo rm -rf ./.Xojo ./Xojo ./.Xojo.Xojo

Now try to start the IDE from the /opt location as your normal user.


I did as you explained, but it didn’t solve the issue.
There is something that I just remembered : There is another issue with my PC (nothing to deal with Xojo) : I can’t rename files in the file explorer(nemo). I have to do it in a terminal using the mv command. I think there could be a problem around ibus, but I am not a linux expert, and I don’t know anything about it.

I intend to upgrade to mint 20, we’ll see then if the problem remains the same.
After the upgrade, I will install Xojo as first application.
After that, I will proceed with the other applications.
But I can’t tell you when I’ll do this.


I just want to make something clear.
In fact, Xojo crashes as soon as I hit any key on the keyboard, not just the arrow keys.