Xojo Cloud - Connection Refused

I’m doing a WebService where I get ‘Connection Refused’ when I Launch it on Xojo Cloud. I use port 8080 (specifik)

When I run in debug mode on Localhost all is fine. I get my JSON response perfectly (via Paw)

Any ideas as to what settings I forgot to change?

Did you open the firewall port?

Yes. It should be open. I have a function (copied from other project that runs fine), and I don’t get any errors during Launch…

I use this in the App.Open so I can access RDS Database, but should I also Open for “HTTPSocket” on a specified port? It is never being mentioned on your WebService examples…?

While EndTry = False
CurrentTime = Xojo.Core.Date.Now
firewall_in = New XojoCloud.FirewallPort(3306, XojoCloud.FirewallPort.Direction.Incoming)
firewall_out = New XojoCloud.FirewallPort(3306, XojoCloud.FirewallPort.Direction.Outgoing)
Self.Timeout = 10

If firewall_in.IsOpen Then EndTry = True
If firewall_out.IsOpen Then EndTry = True
If CurrentTime.SecondsFrom1970 - LoginTime.SecondsFrom1970 > 30 Then EndTry = True

If so, can I use same Var 'firewall_in" for both ports?

I have now tried to also open port 8080 at webService Launch, but still “Connection Refused” from Paw??