Xojo Cloud being persnickety ... won't upload.

Alas. My Xojo Cloud instance is refusing to accept uploads.

The dreaded message from the firewall of hell … “An error occurred during Xojo Cloud deployment. Please wait a few minutes and try again.”

Any thoughts ? Yes I have waited a few minutes. And a few minutes more.

I deleted the application via control panel.

I restarted the server via control panel.

Also sacrificed two water bottles and a can of coke to the deity.

Deity is unmoved. Perhaps the knowledgeable folk at Xojo can work greater magic than the programmer’s deity.

Tony Barry

OK waited an hour rather than a few minutes.

No change. Error on deployment.

Think it’s over to the Xojo people to offer healing to my Cloud.

Tony Barry

Have you tried logging into the admin panel & restarting your instance. I think there’s an option to do this, but don’t own a cloud account (was a tester though).

Sometimes it helps to make a new, blank Xojo web project, then upload that to the same Xojo Cloud server, and THEN try uploading your original project. This has solved the uploading issue several times for me.

And as Wayne said, restarting can also help, but I’d try both of these.

Hi Tony - did the restart help?

Hi Jason,

It did not, alas. Again. The same error. Wait a few minutes and try again.

When I go to the site, I get a 403 - forbidden error

“You don’t have permission to access /fitbitauth/index.cgi on this server.”

The project has been uploaded a number of times before. The changes in this version are minimal, and reflect no structural alterations.

I have now restarted the server three - four times, deleting the app before the restart. I have shut down my Mac and restarted it. Restarted Xojo (of course). No change.

I have tried Tom Iwainec’s suggestion of uploading a blank project (dummy-Dev). It also fails to upload with the same error, and cannot be accessed via the web with the same 403 error.

Any more thoughts Jason ? I am eager for any insights.

Tony Barry

PS it’s 11pm here and I will hang about for another hour or so - but I have to get some sleep too. It would be really nice if this were working by tomorrow. I have to use the fitbitauth app tomorrow …

Ok…we’re looking into it.

Hi Jason,

Any thing you need me to do, please ask.

Tony Barry

Sorry about that Tony. It should be working now.

It’s been healed !! It’s a miracle !!


Thank you Jason. Muchly appreciated. You guys rock.

Tony Barry

Glad to hear that it’s working now!