Xojo apps run on which NAS?

Hi all,

I thought a thread on which NAS models are suitable and confirmed to run Xojo apps might be useful.

So if you run Xojo apps on an NAS then please share your experiences here.

AFAIK: Xojo Apps should run on only Synology NAS with an item Processor.

I would have thought that any Linux or Windows based NAS with an Intel processor might be suitable, but there is no real data. Hence this thread.

Seems I read (on this forum) that someone was running XOJO webapps on the webserver of a Intel based Synology box.

BUT be aware that just because it says Synology on the outside, does not mean there is Intel on the inside.

I know that my DS211J is NOT Intel Inside

I’d also be interested in knowing whether an app can be built for a Synology NAS (not a web app, but a “desktop” one).


I don’t know a NAS that has a real desktop, most have a webpage that mimics a kind of a desktop. Most of those NAS’s have an Intel or ARM processor and can run console and web apps. I have a Zyxel 520 and have tested with some web- and consoleprograms.

In order to run a Xojo Desktop program, the NAS would have to be running macOS, WIndows and perhaps the right flavor of Linux… Most (especially Synology and QNAP) do not, they either run a proprietary OS, or a highly modified version of Linux.

some synology NAS can run virtual machines so you could run Windows as desktop and RDP into it

Did not know this… doubt mine supports this (its an older DJ211 on its 2nd set of drives :slight_smile: )

yeah probably needs a DS model with upgradeable ram.
You could download virtual machine manager in DSM and see.
Sometimes things work if you turn on beta packages. Not supported though…

[quote=456502:@Russ Lunn]yeah probably needs a DS model with upgradeable ram.
You could download virtual machine manager in DSM and see. [/quote]
I’ve tried that on my Synology DS 218+ - Ubuntu Desktop can easily be installed in the VM running on the DS.
I just don’t see the point why one would like running a “Desktop” app on a NAS…

…but I know a NAS is a convenient “lightweight server”, so I use Docker on Synology, e.g. to have cubeSQL or Xojo Console Apps (such as Aloe) running there.

My version of DSM ( doesn’t even offer the VM as a download option…
I’m guessing it because it has an ARM processor and 1gig of memory (its 8 yrs old so no surprise)

My QNAP has a real Desktop. It‘s a hybrid NAS. In Desktop Mode, you have full access to the NAS Hardware locally, but you can‘t use your App on this Desktop in a Browser of course. You need to attach the NAS to a Screen and use it like any other Desktop Computer.

@Dave S
Yeah. Think you’re out of luck then!

Nearly Christmas though. Maybe Santa will bring you a new NAS

Console apps seems to run fine on Synology DS1512+ and DS1515+. Not tested web apps nor the desktop apps. On the DS1515+ you can run VMs and Docker is also available. Syno DS1512+ is no longer available for sale.

Hope that helps

For 2 years back … I had it running on Qnap Intel based… worked fine… Haven’t tested recently…

I see a real interest in console apps running on a NAS
but frankly, not at all for a desktop app on a NAS.

[quote=456557:@Jean-Yves Pochez]I see a real interest in console apps running on a NAS
but frankly, not at all for a desktop app on a NAS.[/quote]

Some of our customers have high spec synology NAS units and they now run sql server in docker and have a virtual windows machine on them that runs our Xojo web services and sites.

Very handy and it’s all replicated and backed up from one place. It works very well, but you do need a quite expensive box! it’s not cheaper than a standard windows server but we do find it very convenient and easy to manage.

This week I had the need to install xojo console app on qnap, and I know I managed before…
After searching turns out that I have lied to all of you… It’s not 2 years back in time it’s around 5 years… Compiling before with xojo 2015r3 (just downloaded today 2013.3 and your applications works INSTANT on qnap SSH console.

But if somebody knows how to run a console app with a current xojo version on a QNAP… Please share.

some details:
64bit app getting this:


./MyApplication: error while loading shared libraries: libgobject-2.0.so.0: wrong ELF class: ELFCLASS32

Strange because uname -a tells me : Linux … 3.4.6 #1 SMP Thu Nov 7 15:14:48 CST 2019 x86_64 unknown
so I assume I’m running on a 64bit system.

and 32bit app getting :
GLIBC_2.7 Missing … (can’t figure out how to install new Glibc on qnap (tried entware but that glib is to old)

And my console app looks like :

run event :
print “hello world”[/i]

not to difficult I think :wink: