Xojo 2022 R4 IDE Fails on all projects

I recently upgraded to Xojo 2022R4 and used it successfully for several days. I have used Xojo for hundreds of projects over the last 20 years.

Today the IDE stopped working in that I cannot add any controls to any externally referenced windows within any project. I have rebooted the computer, downloaded and installed Xojo again and tried to create an empty new project, but the IDE no longer allows ANY controls to be added to ANY window that is store external to the project file (all of our projects store all Xojo classes externally). If you create a window that isn’t externally referenced, the IDE still works. For now, I’m forced to switch back to 2202R3.1 which continues to work.


Which OS?

I had something similar with one of the Xojo betas. I couldn’t drag a control to my windows. A couple of minutes later everything worked fine again. Ventura beta 13.1.

That external file, is it on a network drive?

All the external files are stored on the local hard drive. The problem started happening today on macOS 10.15.7.

I went to an older iMac with macOS 10.13.6 and installed a fresh copy of Xojo 2022R4 downloaded today from Xojo’s website. The same problem occurs on every project. I even created a new project with one window, saved that window as an external file. Deleted it from the new project and copied it back into the project as an external file. Same problem.

For some reason the 2022R4 IDE stopped working today for all projects from multiple computers with different OS versions.

I downloaded Xojo 2022 R3.2 to the macOS 10.15.17 computer. While you “can” copy a button control to a window that resides in an external file, this build of the IDE also has a fatal bug. You cannot select and delete the button control. If you select the button control and press “Backspace” key or select it and choose Delete command from the Edit menu, in either case the button is NOT delete.

Worse yet, once your project is in this state, if you click to select that button control, the IDE exits that form editor.

Do you think that such a glaring problem would have been found by other users? Of course, that would happen. So it’s likely that the problem is on your side.

Too old OS version for 2022r4… Check the Documentation for more details on minimum OS version for the current Xojo IDE.

1 Like

possibly not.
something related to property shadowing has been broken in the past few releases and so far, nobody apart from me seems to be affected.

I checked the example in Harolds vague ticket and I can edit the project fine. And yes, Xojo has those wonderful specific bugs.

In the Issue, Harold shared an example (that failed): the external window is not a DesktopWindow. Once I chanjged the super, it compiles and I was able to add a DesktopPushButton in both windows. Look at the Issue… for details.

I have a few more clues to this issue(s) in Xojo 2022R4. If I double-click on the control in the library panel, it does add the button control to the Window and now I can drag it into place. However, if I select that control and press “delete” button, it will sometimes not remove that control. Instead it puts that control into a corrupted state. Once in that state, any time you click on that button control Xojo leaves the form editor. From this project, I have found no way to remove that button control.

Once in this corrupted state, I can usually create a dummy project and reference this external window and then select and delete that button control.

When I change the class from “Window” to “DesktopWindow” I can now drag a button control from the Library panel to the window. So far I haven’t been able to reproduce the issue where the “delete” button will corrupt that control.

If you can reproduce that in a simply project (the simpler the better) and raise an issue detailing the steps required that would be good. It would also be worth attaching a broken project to the report.

Here is a link to a tiny zipped project that demonstrates the issue. The issue of dragging a button control from library panel to the form is 100% repeatable from my two machines.


Yes, report it on issues:


So that it can be looked at and addressed. Providing steps by step guide helps them a lot.

Likewise I have seen oddities in 2021R3.1 where it would not delete a control placed on a window, and issues with placing controls on complex container controls - placing a control failed (ie nothing happened).

However, these were not sufficiently repeatable - usually restarting the IDE or in some cases rebooting cleared whatever it is. Hence without it being repeatable not worth reporting.

There’s also an issue where the IDE doesn’t catch nilobject exceptions. This seems to be where the window has one or more properties that happen to be nil objects, if code attempts to access these as the window opens will crash the IDE. I’ve seen this in both 2021R3.1 and 2022R4. In 2022R4 it was repeatable in one of my large projects, but so far I have been unable to make a simple repeatable demonstration of it to submit as a bug report.

sorry but I use the 2022r4 on this same 10.13.6 macos and it works fine.
10.14 is recommended, but not mandatory.