Xojo 2018R2 - IDE Extremely Slow

Hey guys, so I’ve been using REAL Studio 2010 for a long time. Recently I’ve been updating some large projects to Xojo 2018R2 for Cocoa and 64 bit. But I’m having a very frustrating issue. The Xojo 2018R2 IDE is extremely slow. Between clicking on a control in the window layout editor and having the control selected, there’s 1-3 seconds of delay. Typing is slow, and has trouble keeping up with my fingers, dragging is non-responsive half the time, and many other things just feel incredibly slugish. I went back to RS 2010 to compare, and it is lightening fast. Everything I click responds instantly, and typing is also 100% responsive.

And finally, when compiling, it takes a very long time. I know 64 bit takes longer, but I can seriously click the Run button, walk away, get a drink, grab a snack, come back, check some websites, and maybe 3-5 minutes later it’s finally running. Even things like quitting a running debug application, and quitting Xojo itself, feel very unresponsive and delayed.

I’ve checked the standard things - monitor memory, restart Xojo regularly, restart my computer, but nothing seems to improve performance. As it is, I cannot work in any meaningful or efficient way like this. Has anyone had any similar experiences, or any suggestions for how to fix this?

I’m on a 2016 MacBook Pro Touch Bar 2.9GHz i7 with 16GB RAM, running on an SSD. I also experience the same performance issues on a 27" iMac 5K, 4GHz i7 with 32GB RAM.

I’m really looking forward to getting my projects updated, and renewing my Xojo subscription for 2018R2, but I need these performance issues resolved first.

Any insight would be extremely appreciated.

There have been reports about performance issues mostly on the Windows and the Linux side.

How large is your project? How many classes do you have? Do you have large methods?

The project file says 25MB. I have I think 2-3 large methods, but mostly they are small-to-medium and quite manageable. Aside from macoslib, I have maybe 15-20 other classes. Some are custom data containers, and others are custom controls. Nothing too crazy. I’m not using any plugins.

Even when I create a fresh brand new Desktop app and drag some controls into the window, I’m getting delayed responses from the IDE.

A few things that may help.

Clearing the Xojo caches can help a bit (under Prefs|Building). Also, I always set “Build Unsaved Apps in:” to a fixed directory on my fastest drive. Make sure you’re not using a Dropbox file-store. Also, try running with minimum plug-ins.

If all else fails try removing Xojo and any residue and re-installing.

This is way too slow. I’ve had to work on my Air for a few days and the IDE is always responsive. The compile time isn’t great but acceptable. And my project is way larger than yours.

Okay, thank you Beatrix. Good to know it’s just me - maybe there’s hope for a solution. I will completely delete Xojo and all related files from my computers and re-download. Thank you for your suggestions as well Tanner, I will also clear the caches. I am building to the same directory that the project is in, which is local, on my SSD, and not in Dropbox. Also, I am not using any plugins whatsoever.

I will report back after I’ve completed these steps. I just wanted to be sure this isn’t an issue everyone is experiencing.


Jeff - I’m not fully sure what that means. So I’m going to say no?

Do a Goggle on “app translocation”.

There have been reports that Xojo does this occasionally. I forgot how to check against translocation. The plugins won’t load in translocation mode.

Deliberately drag the Xojo app to some location like desktop (not creating an alias)
Then drag it into Applications folder.
Dont put the App itself into the taskbar- if you want it there, create an alias and put the alias on the taskbar.
Make sure you don’t have the app or your builds in an area that is being mirrored by iCloud or Dropbox.
And restart your mac.
One of these things may sort it out.

Depending on the complexity (read: containers/pagepanels and a lot of controls) this is expected. I have some bigger projects that also making the Xojo IDE. Clicking on a control or selecting a bunch of controls is slow and troublesome.

I learned to live with it.

[quote=403174:@Tanner Lee]A few things that may help.

Clearing the Xojo caches can help a bit (under Prefs|Building). Also, I always set “Build Unsaved Apps in:” to a fixed directory on my fastest drive. Make sure you’re not using a Dropbox file-store. Also, try running with minimum plug-ins.

If all else fails try removing Xojo and any residue and re-installing.[/quote]

The tip about building on a fast drive and, most, importantly, not working on a dropbox folder, is one of those things that can make ages of difference.

Something that tends to hit me frequently is copyFiles build steps. For debug builds it makes more sense to load the files from a directory than copying them over each time (which adds wait before the app runs), for example.

I always have very fast systems to work with. Atm it is the latest MBP with about the fastest SSD. Still, the GUI cen be extremely unresponsive. It has been the case with Xojo 2016and upwards.
Clicking on controls does not involve HDD/SSD access.
So don’t blame the hardware in this case.

Thanks Jeff, I will try that.

Christoph, I do use a number of pagepanels and tabpanels, but I’m afraid I cannot “learn to live with it”. RS 2010 was lightening fast and extremely responsive, and moving to Xojo 2018R2 feels like using a ten year old computer. It is almost unusable, and productivity will decrease exponentially if this is something I just have to live with.

Eduardo, good info. I definitely always use a fast local drive and no Dropbox. I have a copyFiles script, but it only runs on Release, not Debug. In Debug, I reference the files locally from my Desktop.

I did get a response direct from Xojo support. They acknowledge the IDE has been unreasonably slow with the latest releases and say they are working on a fix. Fingers crossed it comes soon… this feels like trudging through molasses, and I have a lot of work to do on these projects to get them 64 bit ready. They did say as a general rule that methods shouldn’t be more than 1-2 pages long when printed. I will have to go through and check for that. There are some methods that I’ve tried over and over to shorten with some success, but I just don’t know how to shorten them any further. It’s becoming difficult.

Today I will be following all of the tips everyone has shared (thank you very much for taking the time), and I will report back with my results this afternoon (USA PST)

<https://xojo.com/issue/53007> Deleting of debug application is very slow on High Sierra (APFS)

This is what they used to say. But trust me, it will have about zero effect concerning slow reacting Xojo GUI. It may have a very slight effect on typing speed though.
The slow GUI, with larger projects, is an issue for over 4 years now and they are working on improving it for 4 years now. It even got worse with the latest Xojo versions.
In my experience, the only way to keep it ‘fast’ is to avoid using Pagepanels and a lot of controls. :slight_smile:

As I said, you will need to learn with it.
Fortunately it is not as worse compared to the Windows version which has an even slower GUI.

Thanks everyone for your replies. I’ve followed all the steps above. Good news is typing seems to be faster. But all other issues remain. The GUI editor, clicking, dragging, and many other actions are still quite slow. It is pretty disappointing honestly. Especially knowing that these issues have been going on for so long.

As I said I’ve been using REAL Studio 2010. Several times I’ve downloaded the Xojo demo and tried to do what I could on it, but it always felt unresponsive and clunky, so I always went back. Now that 64 bit is being required by Apple, I really have no choice.

My only hope is that the dev team at Xojo can get this sorted out soon. It seems silly and unusual that so many people are putting up with this incredible loss of productivity and fluidity. Here is my latest email to Xojo support:

Thank you for your reply. I’ve done a number of things and the code editor itself now seems better. Unfortunately, it’s the UI editor that really suffers. I’m getting lost clicks, delayed responses, selections and dragging that are unmanageably slow, causing over-drags. It makes designing the UI extremely difficult and frustrating.

Coming from REAL Studio 2010 it is quite a shock. Many folks have said this has been going on a long time. Indeed, I’ve checked out Xojo demos throughout the years and always felt it to be leaps and bounds behind REAL Studio from a speed and fluidity standpoint. Example - why can’t I start typing the name of a class or window in the navigator and have it be selected like in REAL Studio? That is a HUGE time saver. Using the filter option is very slow, taking several seconds to respond to clicking in it, and another several seconds for my typed text to register and a result to be shown.

Please prioritize making the GUI more usable in coming updates. It really is destroying my productivity. And combined with the slowness of compiling, it just feels like I’m constantly trekking uphill through mud.

I will most likely renew my subscription so I can get my 64 bit apps out, but I must say my satisfaction with RS/Xojo is pretty low right now, when it used to be quite high.

If you have a beta program, or if there’s anything I can do to help you guys with speeding things up, sign me up. I’ll be counting the days for an update.

I understand these are difficult problems to solve, and I don’t mean to sound negative. It’s just frustrating when using a new version of something feels like stepping back years from a performance standpoint. I still like and appreciate Xojo as a whole, and I want to love it again. You guys have done great work from a functionality standpoint. Now please just give us a responsive and enjoyable IDE and it’ll be perfect.

Thank you.

This will improve soon in the next release (Incremental compilation).


Perry, I don’t doubt you are having issues, but FWIW, I see absolutely nothing of the sort that you see. I use a 2017 5K iMac at home and a little MacBook Air from 2012 on the go, both running High Sierra.

Have you tried creating a brand new user account and running it there as a test?