Xojo 2017 R1 Installation issues

After installing Xojo 2017 -R1 in nac osx 10.8, i am unable to open Xojo IDE when i click on the Xojp application icon in my laptop.
Please help how to proceed further.

Try running it from the terminal. It may give you more info.

open /Applications/Xojo 2017 Release 1/Xojo.app

If have seen this happen on a hackintosh laptop. Any change you are running such system?

I Tried opening Xojo Application using the terminal window , The verification of the application is happening and Xojo application icon is displayed and stuck . Yes i am running the application on the mac book pro laptop with Operating system version OSx 10.8.5.

Mountain Lion is deprecated.

See http://developer.xojo.com/system-requirements

You probably need to upgrade to Mavericks.

Thanks for the help i will upgrade the mac and check

[quote=327337:@Michel Bujardet]Mountain Lion is deprecated.

See http://developer.xojo.com/system-requirements

You probably need to upgrade to Mavericks.[/quote]
2017r1 should still run on 10.8

i’ve seen this with other apps, too. the app is just ‘jumping in the dock’ (while being verified, which never completes).
it happens occasionally if ‘system preferences -> security -> allow apps from: (x) MAS and verified developers’ is active.
the workaround is to set this to ‘allow all’, then launch the app (which will no longer be ‘stuck’ at verification).
once the app has launched successfully 1x, then you can set the security-preference back to ‘MAS and verified developers’.

there most likely is a terminal-way to achieve the same, but the above is the easiest one to explain to your (pre macOS Sierra) customers, should someone contact you because of your app behaving like that on their computer :slight_smile:

ok. I installed 2017r1 on a fresh 10.8.5 VM and there is definitely some slowness there… and if you have a lot of plugins, I could see it taking a really long time to load. Here’s what I suggest:

  1. Make sure there aren’t any other copies of Xojo already running. Either reboot your computer or use Activity Viewer to find and quit any instances that are already running.
  2. Move the plugins folder out of the application directory temporarily
  3. Try launching the IDE again. This process may still take a while. On my VM with an SSD drive, it took a good 2 minutes from the double-click to when the licensing screen appeared, and then another 30 seconds to get to the project chooser.
  4. Once it launches, quit the IDE and put the plugins folder back and try again.

Note: Check the compatibility on your plugins as well. Older plugins have been known to cause loading problems.