Xojo 2016r3 not executing in Linux Mint

I’m trying to get myself familiar with Linux Mint.
Yesterday I installed 2017r2.1 and that version run well.

Today I installed Xojo 2016R3 and installed various required linux libraries.
Now when I try to open the Xojo program, nothing happens.

ldd Xojo gives me following result.

linux-gate.so.1 => (0xf7702000) librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf76d7000) libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf76d2000) libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf76b4000) libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf74fe000) /lib/ld-linux.so.2 (0x5658b000)
Am I right to believe that the library/connection to linux-gate.som.1library is missing?
What more is needed to make Xojo work?

I’ve started all over with a clean Linux Mint.
The required libraries were installed and a fresh Xojo 2016R3 downloaded.
Unpacked the tgz and tried to start Xojo.
No succes.
I get an error.

[code]Failed to execute file “Xojo”.

Failed to execute child process “/home/paul/Applications/xojo2016r3/Xojo” (No such file or directory).[/code]

The mentioned path is the correct Xojo path, the file (Xojo) does exist and is an executable.

drwxr-xr-x 11 paul paul 4096 Sep 6 2016 . drwxrwxr-x 3 paul paul 4096 Oct 26 14:07 .. -rw-r--r-- 1 paul paul 13849 Sep 6 2016 appicon_128.png -rw-r--r-- 1 paul paul 1817 Sep 6 2016 appicon_32.png -rw-r--r-- 1 paul paul 2326 Sep 6 2016 appicon_48.png drwxr-xr-x 2 paul paul 4096 Sep 6 2016 Documentation drwxr-xr-x 21 paul paul 4096 Sep 6 2016 Example Projects drwxr-xr-x 10 paul paul 4096 Sep 6 2016 Extras drwxr-xr-x 2 paul paul 4096 Sep 6 2016 Plugins drwxr-xr-x 2 paul paul 4096 Sep 6 2016 Project Templates drwxr-xr-x 2 paul paul 4096 Sep 6 2016 Read Mes drwxr-xr-x 2 paul paul 4096 Sep 6 2016 Scripts -rwxr-xr-x 1 paul paul 52731317 Sep 6 2016 Xojo drwxr-xr-x 2 paul paul 4096 Sep 6 2016 Xojo Libs drwxr-xr-x 20 paul paul 98304 Sep 6 2016 Xojo Resources -rwxr-xr-x 1 paul paul 61839 Sep 6 2016 xojo.xpm

I have no clue what I’m doing wrong.

This should be in the Pre-Release channel.

2016R3 is an old version

Iis it a 64-bit installation?
Installed the 32-bit libraries?

@Frederick Roller
??? Why?
This is about release 201R2.1 and 2016R3 and has nothing to do with the upcoming Xojo release.

I was able to get rid of the Failed to execute file “Xojo.” message.
When I tried to run 2016R3 from the terminal prompt, I got following error.

Failed to find/load Framework library libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

Finally, I have 2016R3 now working in Linux Mint.

Beside the always required libraries mentioned in System Requirements, I had to install “ia32-libs-gtk”

Oops. I misread and thought it was 2017r3. Please ignore.