Xojo 2015 R2 crashing when Running the project

Hello guys,

Thanks for the new update, unfortunately i cannot use it at all, it seems that when i press Command + K it does not show me any error but when i press run on the project that works ok on 2015R1 it crashes the IDE .

It generated 3 reports already, 38935, 38936, 38937 all of them pointing to the same error.

Location: MacOSAppBuilder.cpp(416)

Condition: 0

Message: Unknown build resource type (11)

Platform: Macintosh Intel 10,103

Please take a look and let me know if there is a quick fix for this or i have to use R1 again.


A sample app helps

We’ve tracked this down to a regression that causes these assertions for projects that have a database dragged into them. The workarounds for now are to revert to 2015r1, click ignore on the assertion dialog, or remove the database from the project.

Thanks Joe & Norman, the app works perfectly now after removing the database from the project, i guess i should remove that from before .

So i can confirm that this was the issue for IDE crash .

I had the same when trying to compile…/deleting the database fixed this issue wasn’t using the database it just sat there.
Thanks Norman!

my post is here:

Great to have it working

I don’t have a database in my project and I can’t compile or run it on Windows in 2015R2, suggestions?

Actually, a third party tool I use has this apparently.

I don’t think I understand the workaround, I get that I need to revert to 2015R1, but what is this assertion dialog and how do I click ignore?

Deleting the database from the project fixed the problem for me as well. Thank goodness for this forum.

I just updated from 2015 R1 to R2 and had a similar problem. (Using SQLite) My program has compiled fine thru many updates until today when I went from 2015 R1 to R2. Tried to run it within the XOJO editor or compile it and it just crashed (XOJO environment) . Deleted the database from the project tree in 2015 R2 , and now it runs fine. This kinda sucks because I liked the ability to view the table structure within XOJO, now I need to go outside to view it.

2015 Release 2.1, just made available, should fix this issue.