XOJO 2015 r1 Weblabel in dialog no display


i still have the weblabel display issue in dialog box. This is the problem,

create a webpage, put a dialog, in the dialog put a weblabel with some text. Put a button to open the dialog. create another page and set as default and put a button to call the webapge with the dialog

Run the webapp, clik to button to show the webpage that have the dialog, open the dialog and you see everything ok,
close the dialog, go back to the first page, return back to the page with the dialog, open the dialog and now you no see the weblabel,

I try with the patch and same problem.

Please help.

The patch doesn’t run under 2015r1 because all of those changes were embedded in the release. Please create a feedback case with a simple example and we’ll take a look.

We experienced a similar problem with one of our web applications using 2015r1. We had previously released the application with 2014r3 with the patch applied. In that environment it worked fine.

Application structure:

  • compiled as standalone Linux executable

  • responds on port 9301

  • hosted on one of our Ubuntu 12.04 VM servers (ESXI 5.1 host OS if it matters)

What happens:

  • Labels are blank on some, but not all application dialogs.

  • This does NOT occur on dialogs that do not change the text property of any labels on the dialog while the program is running.

  • On those dialogs that do change the Text property of some labels while the program is running, the remaining unchanged labels appear as blank.

  • If code is added to assign a new value to the Text property of one of the labels that did NOT display, it will then display correctly.

  • The newly assigned Text property value MUST be different from the IDE assigned value or the label will remain blank.
    Example: Assigning lblDescription.Text = “Description” when the Text Property was assigned to “Description” in the IDE has no effect.

  • Preserving the original Text property value, then assigning an empty string to the Text property, followed by reassigning the original value corrects the problem.

Our Interim Fix

  • Sub-Class the WebLabel class

  • Add an Invalidate Method to the new Sub-Class that clears the Text Property and assigns the original value back to the Text property.

  • Replace the labels on the dialog with the new sub-classed label.

  • Use a For/Next Loop to walk the control array in our mm_clear method (resets dialog values) . Each control that is identified as a type of the new sub-classed label gets its invalidate method called.

This fix seems crazy, but it solved our problem.