Xojo 2014r2.1 Quit at Build time

The case is a bit complex, but easy to reproduce:

This happens each time I tried to build the applications.

  1. I get an alert who says:
    Files with conflicting names already exist; Do you want to replace them ?

  2. Then, click in Replace:
    This application has encountered a fatal problem and must be shut down.

Then Xojo 2013r2.1 quits (and eventually does not saves the eventual unsaved changes).

Nota: if the project was saved before trying to build the StandAlones: no problem.
BUT, if it is not the case, you get a warning asking if you want to get the changes back (at reload time), but the recovered project is loaded as NEW !
In that case, you loose the original create date properties because you have to save the project as New.

The project is in an External Hard Disk:

60GB IDE HS in a USB 2 box (a 2003 HD that comes from a crashed laptop, formatted and now in an external box)
Hard Disk format is ExFat.
That hard disk is used on OS X 10.9.5 (MacBook Pro, 2011-11) and Windows 8.1 (2 in 1 laptop build in 2014).
That hard disk have more than 59GB of free space and the project size is ~ 3MB.

At last, this does not lead into a crash, you just cannot build an application.

LBN: The “Builds - ” folder have been created.
I deleted the previous StandAlone (Windows application), trashed the “Builds - ” folders and ask for a new build. The Windows Build is created, the alert window appears after the “Builds - ” folder + Windows Child have been created.
Permissions: Read and Write are allowed (from root to the project folders).

BUILD SETTINGS: Windows and This Computer (that is this MacBook Pro) are checked.
I cleared the “This Computer” CheckBox and the compilation (create the Windows Stand Alone) worked fine.
Compilation with only OS X checked; the process goes fine excepted: no application in the folder.
Compilation with only This Computer checked; the Stand Alone OS X application is created in the folder and can be run.

I wrote this report in two times, letting me time to be sure of what happens.

The Feedback reference is:

35511 - Xojo 2014r2.1: Unexpected quit at build time

Crashing is definitely a bug
Do you have “Use Builds Folder” turned off for this project (see the Shared Build settings) ?
You’re building this to an ExFat disk - what if you move the project to an HFS/ HFS+ (mac formatted) disk ? and build it ?