Xojo 2014r2.1 Crash on 10.10.1

A few minutes ago all was fine. I installed 10.10.1 and Xojo refuses to launch and crash:

Crashed Thread: 0

Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/…/Frameworks/XojoFramework.framework/Versions/A/XojoFramework
Referenced from: /Users/USER/*/Xojo.app/Contents/MacOS/Xojo
Reason: no suitable image found. Did find:
/Users/maxprog/Dropbox/Applications/Development Tools/Xojo 2014 Release 2.1/Xojo.app/Contents/MacOS/…/Frameworks/XojoFramework.framework/Versions/A/XojoFramework: code signature invalid for ‘/Users/maxprog/Dropbox/Applications/Development Tools/Xojo 2014 Release 2.1/Xojo.app/Contents/MacOS/…/Frameworks/XojoFramework.framework/Versions/A/XojoFramework’

/Users/maxprog/Dropbox/Applications/Development Tools/Xojo 2014 Release 2.1/Xojo.app/Contents/MacOS/../Frameworks/XojoFramework.framework/Versions/A/XojoFramework: code signature invalid for '/Users/maxprog/Dropbox/Applications/Development Tools/Xojo 2014 Release 2.1/Xojo.app/Contents/MacOS/../Frameworks/XojoFramework.framework/Versions/A/XojoFramework'

Any idea?


Are you using Xojo within shared Dropbox Folder? This would explain why the code signature seems to be invalid.

Yes I do, and did for a years actually, with several version of RB and Xojo and on several computers, worked with up to 10.10… on 10.10.1 that no longer works (for Xojo). I have more than 20 apps on Dropbox, 19 works as usual as usual and 1 not, Xojo… :-/

From my understanding Dropbox doesn’t work as a typical HFS+ drive, it causes all kinds of weirdness with relative links (which are required parts for a framework).

FWIW, I’ve been using dropbox as an active project repository for a few years with incident. Debug apps ran fine from it (I eventually changed debug location to local SSD).

Haven’t tried with with full apps yet…