Xojo 2014 r2 - Crashing Debugs/No working EXEs

Anyone else experiencing desktop applications building during debug-time and never displaying, only for the IDE to revert back to edit mode? I have managed to build projects into EXE’s but even those never display. They appear in the Task Manager for a brief moment and then disappear. Guess I’m stuck with 2014r1.1 until 2014 r3 is released :frowning: I can manage to get an empty desktop project to build and debug though. As soon as you start adding buttons and textfields/textareas its game over for debug-build and working exes.

On a plus side…did notice better performance in the IDE and many bugs are gone. But this IDE is completely unusable if it can’t run or build working EXEs :-/

Saddened because the new IDE performance is way better than previous releases…

Platform: Windows 7

Haven’t had a single issue w/ builds/debugging with the new release, in console, desktop and web… so I’m of little help. And, I’m sure you have… but have you tried completely deleting the debug build directory before trying again, just in case it’s an issue of the existing build that’s in there not getting properly removed or overwritten?

Not having any troubles here either on 8.1 though. Could it be a/v?

Sometimes, when the IDE is doing really strange shit, I clear the plugin cache and restart the computer. That shouldn’t do anything but I’ve seen it time after time work.

Can we have this as a Xojo designed option in the menu like Xojo->Clear caches ?

Bob, how do you clear the plugin cache…?


Delete all the files in the directory. On Mac OS X it’s ~user/Library/Caches/Xojo/. Not entire sure where it is in Windows and Linux. I rarely do any development in them.

And to be clear, restarting Xojo isn’t enough. There’s something about restarting the computer that fixes whatever the problem is. Temporary files perhaps?

I had this problem just last week where the database code the Database.Error bit was ALWAYS true. Well, it acted like it was true even though the debugger value was false.

And now that I reread Matthew’s post, I think if he deleted the builds folder and rebuilt it would probably work. Or at least that would be my first step. The clearing of plugin cache and restart is what I call my bat shit crazy fix (because it shouldn’t do anything).

I think I’ve tried everything so far…

  1. Cleared C:\Users\Matthew\AppData\Roaming\Xojo
  2. Tried deleting the entire Xojo roaming folder and reinstalling Xojo and reactivating Xojo.
  3. Uninstalled and reinstalled (5 times now) even did system restarts (just in case some libraries had to register at startup).
  4. Checked the system log ==> some spawn compiler.dll error occurs at some point during debug-build/building the EXE (Did a search and that’s found at “C:\Program Files (x86)\Xojo\Xojo 2014r2\Xojo Libs\Spawn Compiler.dll”)
  5. Tried replacing Spawn Compiler.dll with Xojo 2014 r1.1’s (don’t do that…Xojo don’t work at all)

I really like the performance of the new IDE plus all the bug fixes, so I’m hoping to find some sort of resolution.

Only effects Desktop debug/build.

Web works perfect

I, too, am running 2014R2 on 64-bit Windows 7 but am not seeing the issues you are running into.

My suggestion is that you (again) uninstall Xojo and the various supporting directories. Then use some decent utility to clean your system’s registry before rebooting and reinstalling Xojo. I had a similar problem a few years ago and found a few incompatible registry entries that had been messing things up.

Good luck.

Just a stab in the dark, and I’m not sure it agrees with your ability to build web project, but I had a similar problem recently. Turns out it was caused by there being 65,535 files in:


  • the vast majority of them belonging to Xojo. Deleting them allowed things to return to normal. Apparently, the IDE was never deleting its old temp files. I also got back about 1.5 GB of disk space (which I had been wondering about :stuck_out_tongue_winking_eye: ).

<https://xojo.com/issue/33796> was marked as fixed just this morning, so hopefully, we won’t have to deal with it much longer…

Edit to add that I am using 32-bit Windows 7.

I had 6 Temp files all rbxxxxxx.tmp files generated from Xojo at debug-time and 2 “scopexxxx” folders. I use TuneUp Utilities 2014 and it keeps my system and registry in tip-top shape (in the video you’ll notice Xojo builds take approximately 3-6 seconds on average to compile :slight_smile:


Here is a small video attempting to run one of my random projects 3 times using Xojo and the result:


You’ll notice with projects containing classes, windows, etc the progress bar to compile is not consistent as with previous builds (which, during compile-time always shows the exact same window/class/etc names) and shows (seemingly random) different classes/windows during compile-time for the latest release.

**On a side note, I attempted to install Xojo on my desktop which contains Windows 8.2 beta and Xojo won’t even open on that system. Decided to try 2014 r1.1 on the Windows 8.2 beta desktop and it fired right up.

I’m determined to make it work.

rbxxxx tmp files are definitely ours
not sure where the scopexxxxxx ones come from

however your video indicates the project compiles & start to run but looks like maybe it crashes

start debug view and see what messages get logged

[quote=107087:@Norman Palardy]rbxxxx tmp files are definitely ours
not sure where the scopexxxxxx ones come from

however your video indicates the project compiles & start to run but looks like maybe it crashes

start debug view and see what messages get logged[/quote]

00000001 0.00000000 [292] pre build
00000002 9.89363956 [292] post build
00000003 14.92556763 [292] Command “RunApp” handled by Window “Xojo - [AFOSR Intelligence.xojo_binary_project *]”

Thats what debugview gives me. (Almost want to factory restore my dev system just to enjoy the new release :-p)

Nothing else ???
Man I hate that there’s no crash logs like OS X & Linux
Those make life a whole lot easier to sort out whats wrong

I see that when I install a new version. I have to specifically add the new Xojo folder to my trusted program list.

Ah yes could be a firewall or anti-virus blocking the debug app from running