Xcode 7 - OOPS

I installed Xcode 7 and now XOJO can’t find the simulator. Now I see that there are a few notes that it will be R3 before it works.

Is there a work around?

You can download Xcode 6.4 from here to use until R3 is released:


I assume I can do a side by side install with Xcode 7 ?

If you need Xcode 7 in particular, then you might want to check out the Beta channel.

The problem is that if you device is on iOS 9 you need xcode 7…

No that’s not true. My devices are on iOS 9 but I am building Xojo iOS apps with Xcode 6.4 installed and the apps run fine.

If you say so. My Xcode Devices window in 6.4 said “Device not supported” when I connected my iOS 9 iPhone 5s. So then I updated to xcode 7 and is now shows up in Devices.

You might need Xcode 7 to use the Devices Organiser with an iOS 9 device. I don’t know about that. I thought you meant that you needed Xcode 7 to write apps for iOS 9 and that’s what I was attempting to clarify. :slight_smile:

I have an iPhone 5S running iOS 9. In Xcode 6.4, there is a alert message at the top of the Devices window that shows “The Developer Disk Image could not be mounted.” I am still able to transfer Xojo built apps to the phone without issues.

I’ve tried to roll back to Xcode 6.4 and I can’t compile - I keep getting “Failed to link files” errors. Seems I’m missing something somewhere. Any idea how to force a total reinstall of Xcode and its tools?

You can download Xcode 6.4 from the link Travis posted above: https://developer.apple.com/downloads.

I’ve already done that and reinstalled, but I’m still getting the error, hence wondering if there is something to force a total reinstall as it seems something is probably still lurking.

Did you delete or else rename Xcode 7?

I first tried renaming - wouldn’t compile. Then I tried deleting Xcode 7 and reinstalling 6.4 again, still won’t compile.

A “failed to link files” error is not necessarily caused by the version of Xcode. I’ve had it happen with an invalid declare. Are you using any declares that you’ve copied and pasted from somewhere else? Also can you run your app in the iOS Simulator? If you can do that but you can’t build then I don’t think it will necessarily be an Xcode issue that you’re experiencing.

The code is the exact same code I last compiled in March and then it completed successfully - there’s not a single change to the code. There are quite a few declares I’ve used from elsewhere for GPS and emails, etc. They worked fine on the last build I submitted to the app store back then.

That’s annoying! Wonder what’s changed and how?

A lot has changed since March. If you’re using declares posted by members of this forum, I recommend you get the latest versions from Github. It will save you time trying to track down issues as somebody has likely already come across these and fixed them. To track down a specific link failure, you can look in the Console for Xojo messages that are logged during the build.

Thanks - I’ll start tracking down the updates. Seems my “5 minute job” is going to take a bit longer than that!

If it helps any, error messages about linking are written to the system log and can be viewed by opening Console.app (located in /Applications/Utilities).

The error I’m seeing is:

21/09/2015 12:22:39.190 Xojo[6024]: ld: framework not found framework