Wrong identifier in "com.xojo.framework"

When I try to submit my app to the MAS, I got this error message:

ERROR ITMS-90334: “Invalid Code Signature Identifier. The identifier “com.xojo.framework” in your code signature for “XojoFramework” must match its Bundle Identifier “com.xojo.XojoFramework””
[2016-10-16 21:19:10 MESZ] DBG-X: The error code is: 1102
[2016-10-16 21:19:10 MESZ] INFO: Done performing authentication.
[2016-10-16 21:19:11 MESZ] DBG-X: Returning 1

My app was build with Xojo 2016 R3

Signed with AppWrapper?

Yes, with Version 3.6.3 (191)

Double check that this checkbox is unselected. It’s disabled now but maybe your settings carried over from a previous version?

This checkbox is disabled and not selected (like in your screenshot).

In the same options panel, do you have “Use Apple’s temporary engine” selected, try switching it on if it’s off, or off if it’s on. I have an idea of what’s causing this.

After the checkbox for “Use Apple’s temporary engine (fastest)”, submitting the app to MAS was successful. I don’t know why I must change this value. I didn’t change any value in App Wrapper for this App. Since my last update about two weeks ago, I don’t use new features or libraries in my app. I have only made a few changes to fix tables from a database.

Apple changes things without telling anyone. It’s all built into their IDE, but we have to keep playing catch up, and Sam is super helpful with that.

I’m getting this same error but am not using AppWrapper (it’s signed in Terminal). Can anyone tell me what to change in the code signature in this case? Right now it’s

codesign -f -s “3rd Party Mac Developer Application: DeveloperID” /Users/jon/Desktop/myApp.app/Contents/Frameworks/XojoFramework.framework

In case this helps anyone else, I came up with the solution. It seems that in Sierra you must also sign


That’s weird, that’s the checkbox that Sam has disabled…