Wordpress with Xojo - conflict?

I have a Xojo WE app: app.cgi
It runs fine on my server at mydomain.net/cgi-bin/myapp/myapp.cgi

Then I installed Wordpress at mydomain.net
Wordpress runs fine, but my app no longer runs from the location where it is still installed (see above). Now I get the error message: The requested document was not found on this server.

Any clues what the Wordpress install did to get in the way of my webapp?

in the root of your account ?
wordpress index.php is probably doing this then
you can install wordpress in a subdirectory usually and that might alleviate the problem

Understood. My desire is to have Wordpress be the face of the domain at the domain root, then lead off to my webapp(s) from links in workpress. What I have done in the past is host wordpress at mydomain.com and the webapp at mydomain.net/cgi-bin, but I would really like to not have to host 2 domains just for that purpose. So I was wondering if there is something I could do to resolve the Wordpress conflict as configured above.

I guess another question is, can a cgi app run from the root of the domain, or does it generally/always need to run from the cgi-bin folder? If I can run my app from the root then my webapp can serve as the face of the domain - which is also OK. I believe I tested this (running webapp from root) and my server host didn’t seem to like that, but not sure if there is something I can do about that.

I’m not an expert…

Is this perhaps a problem with your htaccess file? Can you ask your ISP if your setup is correct? Can you move your cgi-bin to a subdomain?

I have the same problem with one difference. Mine is a standalone Web App.
My wordpress site is at mydomain.com and I am trying to deploy a standalone Web app at mydomain.com/myWebApp.

Some time ago I tested this on a Ubuntu 10.04 VPS and it worked without any problems.

The WE app needed to be in the CGI folder but otherwise there was no limitation. I could launch this app and load it into a WP Wrapper (iFrame). Worked just as well with Joomla or selfmade websites, when I tested RapidWeaver and Freeway Pro.

For more information on the Wordpress wrapper look here:

My tests were on a VPS of Hosteurope, here:

@Mark Pastor Wordpress uses rewrite rules as I know. So It will catch the calls to your App.
Easiest will be to use a subdomain for your WebApp. Or you have to exclude this path from rewriting.

@Chip Gillespie Using the Standalone App in an folder is only possible with something like nginx proxy in front of your machines.
Standalone Apps have to have their own port. So they can’t share it with apache or so.
The easiest Way for you would be to set the Webapp to a different Port (perhaps 8080) and put it in an iframe.


Thanks. I will give that a shot.

Thanks Marius, I switched to cgi since I just discovered that its easier to implement SSL

Still testing… but turning off the rewrite engine and changing the port to something other than 80 in the .cfg file got it to work.
Does the cgi WebApp need to have a different port than the domain root? - this seemed odd to me.

Next I will try adding this line with the rewrite engine turned on:
RewriteCond %{REQUEST_URI} !^/(cgibin|cgibin/.*)$

Jepp, you can’t use two different deamons on the same port. You have to set it to a different port.
Turning rewrite Engine off, won’t do the trick. Wordpress needs the Rewrite engine.
You have to exclude especially the Webapp-Path from rewriting it to Wordpress…