WindowsSoundPlayer error

One of my users is getting an odd error that I’ve never seen before. When she hits the play button (BevelButton, not on the MoviePlayer control bar), she gets an error that says “Common/Win32/WindowsSoundPlayers.cpp:285 Failure Condition: 0 (null)”. Any idea what is causing this? I do not get the same error. Also, her movie plays fine in QT Player. The BevelButton is calling This sounds like a Windows system error to me, but why does it only affect my app and not QT Player?

MoviePlayer.PlayerType specifies the player to use (Default, QuickTimer or Windows Media Player). How is this set in your app? Could you be using QuickTime, but the user does not have QuickTime installed? What version of Windows?

I just remembered that it plays the video in a loop and makes a beep at the end of the loop. It could be that the beep did not get compiled with the app. Checking on it now.

I think that was it, but i’m not sure why the beep isn’t showing up in the compiled app. I had to relocate it when I opened my project to make changes. It doesn’t seem to be compiling with the project anymore even though. I’ve tried it both as a .wav file and .mp3 now.

When the user clicks the play button and the beep checkbox is checked, the sound is on a timer to beep every 4 seconds. “Morse” is the name of the sound file and it’s an MP3. Morse is in the project window.

if BeepBtn.value = true then if Morse <> nil then else msgBox "sound file is missing" end if end if

I’m getting the error msg when i play it. This used to work fine.

Did you ever find a solution to this, Patrick? I’m encountering the same problem but not reliably reproducible.

I’ve tracked down the source of this, at least for me.

If there are no sound devices installed in Windows (see the Sounds control panel), playing a sound crashes the built app and sometimes the debugger. However, newer versions of Xojo don’t seem to have this problem. (Crash was with a build from 2011r4).