"Windows Resources" folder clarification

Hi all, a question about the Resources folders on Windows. We are moving our main application from 2014r2.1 to 2015r3.1. Previously Windows had a single “Resources” folder that we copied some database files into with a CopyFilesStep in the Build automation area, works fine. In the newer versions of Xojo, it copies them into a “Windows Resources” folder and puts all of the programs needed graphics into a “MyApp Resources” folder.

MY QUESTION: As we are changing the setup scripts to accommodate this change, is it proper to copy them out to the same two named folders in program Files that are next to EXE in the final resting area after the user installs? Or is it better to copy them both into one of the Resources folders, and just end up with one Resources folder on the user’s machine in Program Files?

You should only be getting ONE resources folder named after your applications name (ie MyApp Resources)
If you’re seeing something different that’d be a bug

I get two folders on Windows, both created at the same level as the EXE. “MyApp Resources” which holds all the pics and icons I have dragged into the Project. I think I read somewhere, these were previously baked into EXE on Windows? And the other Folder I get is called: “Windows Resources” which has the 3 database files in it that are in my Build CopyFilesStep. I have seen this for quite a while in Beta testing, but not using the newer versions in production apps yet, I didn’t pursue it, just assumed that was how it was after changes.

Should “MyApp Resources” house my 3 database files as well as the pics and icons the compiler puts there for use at run time?

It should

Nope, looks like a bug. I tried removing them and re-dragging them from Windows Explorer again. I also removed them and added them with the buttons, same results: 2 Resources folders created.

I’ll see if I can work up a small example and for a FB case.

No Luck, small test project behaves as you said it should.

Does your copy step shove them in a subfolder of its own making ?
IE/ is it copying into the App parent with a subdirectory specified ?

Not sure I understand the question. The 3 DB files are in 2 subfolders in my project source area:


I just drag them into the CopyFilesSetp window in Xojo and they look like this afterwards inside my Project in the IDE:


Then after I build, a copy is made of each of them and put here in this folder:

My_EXE_Folder\Windows Resources

I don’t create the “Windows Resources” folder, that is done by Xojo if that is what you are asking. And of course, everything else goes into “MyApp Resources”

The copy file step can itself be set to copy into the resources
OR you could set it to copy to the same dir that contains the app executable and custom subdir name

Click on the step & look at its setting in the inspector and you’ll see what I mean

No subdirectory is set in the Inspector for any of the 3 files. And the Destination is “Resources Folder”.

I added a subdirectory called TestNorm and it puts them in:

My_EXE_Folder\Windows Resources\TestNorm

So the subdirectory field is working, just the Resources folder is set to “Windows Resources” for some reason.

Wish you’d reported it when you first saw it
Please do so now though
You say a new small app doesn’t do this ?

I thought it was working correctly since there were changes to the Resources folder, otherwise I would have. New test app works properly as you explained.

When I run in Debug mode in the IDE, I get two folders after a run:

DebugMyApp Resources
XojoBeta.MyApp Resources

Where “C:\XojoBeta.MyApp” is my main source folder that I have used for the 3.1 beta. In Debug mode, the extra folder is picked up off the name of my main source folder. But when I build it is picking up the “Windows” I guess from C:\Windows?

Let me experiment with this in the test app and see if I can get it to fail. Right now I don’t have anything to give you as an example.

In the test project, I just have a button, one .png file that was dragged into the project and another png that is copied via a CopyFilesStep and is not in the project at all. Both end up in the MyApp Resources folder.

ALSO: I tried it with Windows as the Target and This Computer as the Target, no difference.

Definitely sounds off somehow

never mind the report
I’m working on something else & think I just found it

Great, hope that is it. Let me know if you need something tested with it.

When we get to the next beta

I think I just saw it here: With “Use Builds folder” option turned off it shows the problem in the Sample Project. Is that what you see?

No I’m working on something almost completely unrelated but it touches on build scripting so I was testing something with a Windows build on OS X
And there it was