Windows builds using Xojo 2016r4.1 & 2016r3 differences on Win server 2008r2

Hi there,

Building the exact same app with Xojo 2016r4.1 and with 2016r3 are giving different behaviour on Windows Server 2008r2.
This is the same project, build with the 2 different Xojo versions.

I don’t see any differences between versions when testing on Windows7 or Windows 10 systems.

When installed on 2008r2 here are the 2 differences (at least the ones I see).
Important: application on 2008r2 is accessed by Remote Desktop, using Terminal Services. This is not for me only, company users have to connect using terminal services.

With 2016r4.1

  • the +/- disclosure signs on hierarchical listboxes are NOT displayed

  • every time the user Quits the app, he gets a Windows error:

Problem signature: Problem Event Name: BEX Application Name: stdc.exe Application Version: Application Timestamp: 58499b34 Fault Module Name: ntdll.dll Fault Module Version: 6.1.7601.17725 Fault Module Timestamp: 4ec49b8f Exception Offset: 00094f52 Exception Code: c000000d Exception Data: 00000000 OS Version: 6.1.7601.

With 2016r3

  • the +/- disclosure signs are displayed correctly
  • no BEX problem

Because of terminal services there could be an explanation for the BEX problem here
I don’t know if it’s possible to add the /TSAWARE option in the build link process.

I don’t have any clues about the compilation and linking processes, nor about the differences at this level between 2016r3 & 2016r4.1.

Maybe you have an idea ?

which version of 2008 are we talking about?

2008 = Vista
2008r2 = Windows 7

It’s also important to note that Terminal Services don’t have hardware acceleration and will not take full advantage of the changes in 2016r4.

A screenshot would be helpful.

Greg, it’s a Windows Server 2008r2 Build 7601 SP1 (Windows7)

OS Version:	6.1.7601.

Here are some screenshots:
Windows version

Hierarchical listbox Xojo 2016r3

Hierarchical listbox Xojo 2016r4.1

Is the app being built 64-bit?

It’s a 32-bits application.

However, I tried 64-bits and the app is working but I have the same problems:

  • BEX problem when the app Quits
  • no +/- signs on listboxes

This may be due to the terminal services as the app works with Windows 7 and 10.

If you run on Windows 7 and select the classic theme do you have similar issues ?

Hi Norman,

On my Windows 7 desktop
With the theme called “Windows Classic” (my Win7 is in French) I have a small square pattern that doesn’t change when the line is collapsed or expanded. The small buttons + and - have no border.
With “Windows 7” and Windows 7 Basic" it’s fine.

On the Server 2008r2
Here I don’t have “Windows 7” or “Windows 7 Basic” choices.
The theme applied is Windows Classic.
I have the same problem when I select High Contrast White, e.g.

Here are some screenshots:

Windows 7 desktop
Windows Classic

Windows 7

Windows 7 Basic

Windows server 2008r2
Windows Classic

High Contrast White

Try a theme OTHER than the “Classic” ones on your server version if you can

The only ones I can select are the “Classic” and the “High Contrast” ones.
Above is a screen shot with the high contrast white.
The other hight contrast are behaving the same (wrong) way.

When I use the app build with Xojo 2016r3 I don’t have any problem… all themes are fine.

We did just have a bug reported against 2016r4.1 and using the classic theme.
Its been fixed for a future version as far as I know.
It’s possible thats the same bug you’re experiencing but without being able to try a different them on the 2008 Server its hard to confirm

Is the “High Contrast White” not different from “Classic” ?
I’ll check with the people in charge if the server if they would agree to make other themes available.
I’ll let you know.

What bothers me more is the BEX issue…

I’ve gotten BEX errors in a Xojo 2016r4.1 web app running on a Windows 2012 server, but it only happened when compiled to 64-bit. Same app worked flawlessly in 32-bit… Didn’t have time to track down the specific cause :confused:

Reminds me to this (]Feedback #11940 in 2010
still unchanged for many years…

[quote=318788:@Tomas Jakobs]Reminds me to this <> in 2010
still unchanged for many years…[/quote]
works right without rdp? and doesn’t work with rdp? makes me think this is an rdp issue at least in part
Not unlike <>

Too long in the past to know any details today. But I remember this was something visual definitely. When started to move the window around or when clicked in the tabbar, the missing items apperead somehow. The original intention was to run my app in seamless RemoteApp mode on terminal-server. But faced with this issues I discarded this plan and deployed my app on the clients directly.

And have had no issues like this? Which again would lead me to suspect RDP at least in part.

I know that at least in part RDP tries to minimize the amount of data it has to send across the network to try & keep performance up BUT if it doesn’t send the right refresh data then you can easily have weird issues like this.
That moving items around caused refreshes suggests thats in part whats going on.

You would not be the first person to report odd issues when using RDP

ja maybe… I’ve discarded this… always have a plan B in developing process and always check everything before offering something you cannot guarantee :slight_smile:

Sounds a lot like “sell what you have”
Far too often we hear that people are begging for “fix X” or “Feature Y” because they promised their customer that they’d deliver something which hinged on one or more things being fixed / implemented

Believe me, I’ve done this too often… getting older… :wink: