Windows 10: App Data missing?

On a users machine Im trying to debug why my app wont start
Convinced its McAfee, but one thing Im also checking is the presence of support files
One should be in Application Data
But even with ‘hidden files’ turned on, I cant find an AppData folder on the machine

Has this changed?

The location for AppData in Windows 10 remains the same:

C:\Users\UserID\AppData

Great.
So since it isnt there, something odd is happening…

appData is invisible.

To see it, you need to check “Show hidden files and folders” in the View tab of the File Explorer Options Control Panel.

Does the user happen to be on an Exchange domain with their entire profile stored on the server?

[quote]To see it, you need to check “Show hidden files and folders” in the View tab of the File Explorer Options Control Panel.
[/quote]
Good thinking. But I did that.

My second throught, but oddly no.
It was a Windows 8 household machine ‘forcibly upgraded’ to Windows 10 according to the owner.
I found one AppData in the Public user account, and nothing in the current user’s account.
Its where I usually put an encrypted licence key, and I needed to see if it existed.

(I eventually solved the problem I dialled in for: the program was struggling to open a different hidden file in the My documents folder.
I strongly suspect McAfee, but resolved the issue by deleting the file so that the app could get past that line of code.)

The shortcut %appdata% will take you to the place where appdata is for that user.

yup. always expect the unexpected.
system defined folders can be where-ever your sysadmin wants them to be.
on a system with a small SSD (C:) and a big HDD (D:) your Downloads/AppData/…-folders or maybe even your user-home will be on D:

but since the OS (should) knows where they are, let it take you there:

1) type in %appdata% in windows explorer's location bar 2) in cmd.exe: cd %appdata% 3) or in cmd.exe: explorer %appdata%

and… you may want to double-check if your xojo built app is picking up the correct folder with it’s SpecialFolder-FolderItems.
it is entirely possible to “screw up” the registry so that not all frameworks are working as expected when trying to locate those system defined folders.
for example: i’ve seen a couple of systems where InnoSetup complained about not being able to find the “userdocs” (i don’t remember the exact variable/message). that folder may be there, but properly registered in the OS.

Should not SpecialFolder.ApplicationData point to it anyway, wherever it is ?

Jeff, how do you point to it ?

Yes it should

Exactly that.
The issue was finding said folder using File Explorer. :slight_smile:

Its there somewhere… once I got past the My Documents file, the app is working fine which means it has stored the licence ‘there’ and can find it again afterwards.

Launch the command prompt and type

CD %appdata%

That will give you the path.

That will work if the appdata is on the current drive.

echo %appdta%

will output the full path even if it is on another drive.

I just ran into this. I was having problem with my work computer and so checked up the Windows Insider 14931 and the App Folder wasn’t there. Even after I checked (to show) Hidden items in the Explorer’s View toolbar menu, App Data still wasn’t showing.

I right-click on my UserID and select Properties. Then check Hidden (to hide all) and Apply. Then immediately uncheck Hidden (to unhide all) and Apply. After this, App Data show up. Because Hidden was initially unchecked, I had to check, apply then uncheck, apply.

Interesting…

Add (either temporary or not) a MenuItem that opens the folder you want…