Why doesn't this work

I have an update routine that downloads a diskimage and launches an installer. The image file is located on my Xojo cloud.

The url would be: https://data.aspe.org/xo/membertree/Test.txt

This works for me and I sent it to @Jason Parsley and it worked for him and some other people that he sent it to. But this does not work for my users.

In a browser they get This site can’t be reached error.

I am beginning to think it has to do with Xojo being installed.

Can anybody offer some insight as to why this is happeninning?

Thanks

Could they be using an older, unsupported browser? I tried loading the URL in a Windows XP virtual machine. Using a somewhat up to date version of Firefox, the URL loaded successfully. Using Internet Explorer 8, the URL was unreachable.

Everyone is using Chrome or Safari. It’s just our staff, maybe 6 people.

Only other thought I have: Is the server located on your Local Area Network, with the domain forwarded to your WAN IP? Your router could need a loopback enabled to access the URL while behind the router.

The server is Xojo Cloud, not a local server. Our sub domain data.aspe.org points to our Xojo Cloud.

Using ip address doesn’t work either.

@Greg O’Lone

Any thoughts on this?

IP address won’t work with HTTPS for several reasons:

  • https requires a SSL certificate where the hostname matches the certificate. When you try via IP address, there is no host name
  • many servers do not have dedicated IP addresss, so many servers are running on the same IP. Which server is used is determined by SNI: https://en.wikipedia.org/wiki/Server_Name_Indication

What’s the exact error message? “this site can’t be reached” is vague, and it’s not clear if this is a DNS problem, a certificate issue, or what…

The exact error is:

This site can’t be reacheddata.aspe.org took too long to respond.
Try:

Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_TIMED_OUT

Not a DNS problem as our apps run fine.

Our Xojo Cloud is a dedicated ip.

Has the IP been changed recently? Could it be a DNS caching issue?

Doesn’t xojo cloud have a very aggressive firewall? Maybe some users are banned?

@jim mckay No I don’t think so. The apps run it’s just the url to the file download.

@Michael Diehr If so I think @Jason Parsley would have mentioned it. I specifically asked if this could be a permissions issue.

[quote=459129:@Richard Albrecht]@Greg O’Lone
Any thoughts on this?[/quote]
Jason is going to contact you directly to get some more site specific information so I can take a peek at it.

I don’t know how the cloud backend works in terms of load balancing, maybe a misconfigured mime type?

I tried the link from windows, and Mac on a variety of browsers.
Its working fine for me, where I am

https://data.aspe.org/xo/membertree/Test.txt

First access:

200 - https://data.aspe.org/xo/membertree/Test.txt
404 - favicon.ico

Next access:

304 - https://data.aspe.org/xo/membertree/Test.txt
404 - favicon.ico


304 = not modified, you can use the last cached you received.

There’s a lot of non-standard traffic being directed at his Xojo Cloud server and our firewall doesn’t allow that. If this is not something that they can/will correct, we can whitelist the specific IP address for him.