WebToolBar

I can not add or modify the WebToolBar buttons. When I go into edit mode, clicking on the button + exits the edit mode,
anyone has this same problem?

I’m using Windows 7 Xojo

I ran into lots of little problems using this widget a year ago. I just avoid it. It’s easy enough to craft your own with a WebContainer, WebLabels, and styles.

-Brad

I always make containers of containers. You have a lot more control and options. You can easily add some methods to the parent container to add and arrange its child containers. I even subclass and nest these multiple times (an interface might be a good idea).

I ran into your WebToolBar problem today and seemed to figure out a workaround. After going into edit mode, click about 150 pixels to the right of your intended target. It’ll work for all buttons, spaces, etc. contained within the WebToolBar control as well.

I’m only able to reproduce this on one project I brought over from RS2012r2.1. WebToolBars in newly-created Xojo projects seem to edit correctly. I’m using the Mac version of Xojo on Mac OS X 10.8.4.

I got the same problem. Edit works if the inspektor is off.

jens

i have same problems but i trait 2013r2 and it works

i have same problems 2013r2 it works some times .
after test and test it have same problems

On Mac Os X work fine but on Windows 7 no works

Someone please file a bug report!

<https://xojo.com/issue/26725> and <https://xojo.com/issue/27998>

This one might be related too <https://xojo.com/issue/28309>

i have the same problem, and my webtoolbar is not in webcontainer.
i see that the feedback case at now is only reviewed (when xojo will close this case ?)

ps.
At now i have updated xojo to r2, and open a real studio 2012 project.
On any webToolBar that i try to edit and add a new button or other, the result is lost focus and i can’t add nothing…

ok,support reply me that this is knowed problem, and will be fix on xojo 2013 r3
:frowning: