WebSegmentedControl

I have a 3 tab segmented control on my web app. I know that the web segmented control has a bunch of issues, but I can’t find this one on the forum; When I go to run the app I get an error "there is more than one item with this name and its not clear to which it refers" The offending line of code is;
ItemViewer.wsc.selected(0) where;
ItemViewer is the host page
wsc is the web segmented control

wsc is used only once throughout the project so there is no control name ambiguity. Any clues?

Post the whole code. Not just one line that is the result of who know what.

This message usually means you are trying to shove an integer instead of a string or the other way around.

[quote=188843:@Michel Bujardet]Post the whole code. Not just one line that is the result of who know what.

This message usually means you are trying to shove an integer instead of a string or the other way around.[/quote]
The help file says that the segment index has to be an integer and there is only one line of code (posted above) in the sub.
Doesn’t matter anyway as I made my own.

[quote=188863:@chris benton]The help file says that the segment index has to be an integer and there is only one line of code (posted above) in the sub.
Doesn’t matter anyway as I made my own.[/quote]

ItemViewer.wsc.selected(0)

This line uses Selected which is a boolean but as it stands it should have something like = True or = False following. The compiler was probably completely lost as what you wanted to do.

Glad to read you solved the issue.