WebSDK Examples not working for me


I have over four versions of Xojo on my computer and have tried to open the WebSDK examples in their respective versions of Xojo (even though they appear identical between versions). I am now using 2023 1.1 (though I have the newest one too). Are any of these supposed to work without modification? So far, I’ve only gotten the Icon converter to work, and that’s a desktop app.

It’s important to me to have a simple example because in the tutorials I’ve read it talks about Namespaces and such, which I’ve never used in Xojo before, and I don’t have any idea where to put this information. I’ve never used Javascript before in Xojo so an actual working example would be a giant bonus.

So, what I want to know is this:
Are these example apps supposed to work unmodified?
Does anybody have a really dirt simple tutorial on how to create anything at all with the WebSDK? I’m talking about really, really simple, because I really don’t get it. That’s why I was looking at the Examples.

Thank you,


Are you loading Examples - Platforms - Web - WebSDK - (examples here) ?

This is CustomButton:


Gravatar also works.


I have Examples/Web/WebSDK (on the versions I have with an Examples folder). No “Platform”. On one version I see “Platform-Specific” but that just contains Windows, Mac, Linux and Raspberry PI.

Can this be a Windows/Mac difference? I’m on the Mac (Macbook M1 Ventura). Maybe our application directories are different? Do I have to move the examples to a new project directory?


They changed the way examples are delivered. You have to launch Xojo, then go through the project chooser. Examples are downloaded from the web. Any examples folder you have is probably out of date.



That’s a new one on me. I’ll try this before I hit the hay.

Thank you,

Well, the tutorials are scarce, I think that the “WebSDK Docs.pdf” in the WebSDK folder and a youtube video are the best options

this modified websdk example for a simple bootstrap button works too “out of the box”
just clic on run and it should go.

What would be the simplest example that you’d like to see? I’m happy to add more if needed.


I agree that these are the two best sources of information on the subject I’ve seen so far. I am continuing to review both of them, assuming that some sort of elaboration (hopefully simplified) is forthcoming.

Thank you,


I did as you said, and at least I saw the directories as explained by Alberto. However, none of the examples work for me. I tried changing my default browser also, thinking maybe Safari might screw up the process. No change. I’m thinking I will go fire up the old Windows PC and try this again. I know there are plenty of Mac users at Xojo, but I can’t think of anything else at the moment.


what are the exacts symptoms you’re having ?
try to describe what"s happening.
normaly you hit “run” and it runs directly in the default browser…

1 Like

I ran the examples with Xojo2023r1.1 (I also have 2023r2, 2019r1.1 installed) on my mac (to be as close to your environment as possible).

If you explain a little more what is not happening we may have some alternatives. For example, I have 2 users on my machine, If one is debugging and tries to run as the other user, Xojo starts the debugging run but then just stops and nothing is sent to the browser, Is this behavior what you are seeing? or do you get an error?

You have two users that are… using the same machine at the same time ?

How can is this possible ?

No. 2 accounts.

One personal one work.


This example doesn’t work either. However, I got one WebSDK example to work on another computer so I’ll try yours again. To answer your other question, I hit “run” and it starts compiling, finishes to the extent that the big black dot signifying “running” is filled in, then it just stops. On my other computer, at that point a browser opens, but on this computer (the MacBook M1) no browser or browser window opens, no error code, no nothing.

Thank you for your help thus far,


I answered a similar question from Jean-Yves. I only have one user, I can open a few WebSDK examples on another computer (Mac Mini 2012 with High Sierra), but no examples work on this Macbook M1. It seems to compile, then returns me to the IDE. I made sure all other web servers were off, discarded my previous versions of Xojo, ran everything from 2023 version 2, restarted the PC, shut down every app except Xojo. As I say, it has to be this computer. The other computer compiles the WebSDK examples slowly and opens them slowly (it’s eleven years old after all) but does open them. I’ve tried three browsers and tested my ports thinking the Xojo server might be enocountering conflicts, but no luck so far (except on the other computer, which is something anyway).

Thank you for your continued assistance,

there is a serious problem on your computer, between xojo and the default browser…
don’t you have any antivirus or firewall app that could block all of it ?

Try changing the debug port

Try manually entering the URL on your browser when you are running the project: (or the selected port)

Can you run other example projects just not WebSDK examples?


I’m sure your examples thus far are just fine for the level of developer you’re targeting. Unfortunately for noobs like me, however, this WebSDK is just too far above my pay grade. After taking a closer look at your examples, I expect to have more intelligent questions to ask you before I request another example.

If I could make a general suggestion which applies to almost all Xojo documentation and video presentations, however: Presuming you’re targeting the new Xojo user (which doesn’t seem to be the case with the WebSDK), emulate Geoff Perlman, who recently came out with the clearest and most readily understandable database videos ever created in Xojo’s history. Unlike the case of the WebSDK, I have a lot of experience with databases in general, yet I found Xojo database videos to be overly complex because they didn’t start at the beginning (absolute zero experience with the IDE) and work from there.

In his new videos, Geoff starts out presuming I’m an idiot (which is, in this case, an accurate supposition) and breaks everything down, displaying every step in the iDE, and when I finish I not only have a working prototype but a fairly thorough understanding of what I just did.

In the case of WebSDK, half the battle with a newcomer to Xojo is not just what to write but where to write it. For example, the first time I had to extend a class, it’s not like I couldn’t write that or understand it, but I didn’t know where to put the “extends” part. Writing it in the parameters box seemed counterintuitive. Ditto for the Namespaces. Not a new concept for me, but where do you declare the Namespace? Little things like this, that you experts assume we know, trip me up for days.

The first day of Xojo programming, I was trying to open a SQLite file, which I have done in PHP, Go, Node, Python and even Rust. Expecting to write a file path or URL, imagine my astonishment when the video’s author confronted me with a “SpecialFolder”, “FolderItem” and “Child”, suggesting I automatically migrate the file to another folder for some reason. Now, as it turns out, all these terms are extremely useful and the concept behind them is a core strength of Xojo in terms of its easy integration into the native file system, but I would argue this was not necessarily the place to start off with the new user–at least not without a good explanation.

Now, I could look all this stuff up–and obviously I did–but this is often a pattern in Xojo documentation. “Webstyle” is another concept I am constantly confronted with, yet is not given a lot of copy in the docs. Understanding your staffing constraints, I would just want all of you to give some more thought to this subject, knowing you’re all doing the best you can.

Thank you for your help and understanding,


“Try changing the debug port”


I took a look at the port earlier, but ignored the debug port. I set the browser to my new debug port in advance, and I’ve got nothing but rainbows and unicorns since then.

Jean-Yves’ example works, every one (that i’ve tried) in the WebSDK folder works, the regular stuff in the Examples folder also works (I’ve been using those for a while).

Naturally, I still have no clue what any of this code is doing, but at least I know that it’s doing what it’s supposed to!

Many thanks to you and the always helpful crew,