WebFileUploader in Xojo Cloud

I am using a Xojo Cloud server for one of my clients. I have access to it, have connected a DB server to it, and have uploaded a couple of apps to it.

The one thing that I cannot get working is WebFileUpload for some support files my app needs. WebFileUploader seems to work but then simply times out and no files are uploaded.

Anyone else seeing this?


More Info: The files I’m trying to upload are all relatively small (<1k). I have my own app that I created but I’m getting the same results with the Xojo File Manager example project.

It also doesn’t seem to matter where I try to upload the files. I’ve tried the app, shared documents, documents, and temporary folder locations.

Makes setting up the server a lot more difficult if I can’t upload any files. And no, I can’t upload them as part of the project upload to Xojo Cloud.

Sounds very similar to something I observed too: https://forum.xojo.com/10532-deploy-not-working-on-development-pc

I filed case #32942. I reported how they can replicate the problem with the XojoCloudFileUploader example.

I ended up making a separate app that just does file uploads. This worked out better anyway because I upload media to a separate folder so if I delete main app the media aren’t touched.

It would be great if Xojo Cloud had a bunch of apps that people could install on their control panel if they wanted to (launched via buttons on the control panel). Also, not sure a Delete button is needed on control panel.

We had this problem before in the cloud beta already.

I essentially created my own version of XojoFileManager during the alpha because I needed files on the server.

Yes, and there was some tweak to my server (it works) but it’s not been included on my clients server (which does not).

We’re looking at the upload issue now. We’ll post an update here soon.

WebFileUploader function and speed issues should now be addressed.

No, no it’s not. WebFileUploader is failing today with various sized files.

@Bob Keeney - Could you answer a few questions for me?

so what’s the failure? timeout? bad file? no file?

where are you uploading to? (on your server)

WebFileUPloader eventually times out and no file is transferred.

Yes, my server, FileShare app.