WebDatePicker - howto please

Hey there,

I want to use the DatePicker in web project.
To do so, I draged it on a webpage, added a start and end date and … had some expectations :slight_smile:
I thought that (running the picker from the ide (debug mode that is called I guess)) I could click it and a calendar would show up where I could easily chose a date by clicking it (and then access it by the “value” property).
Unfortunately I only see the header with the days of the week (Mo - Su) and no dates to pick at all.
What am I doing wrong?

My number one help is documentation.xojo.com but I noticed that with Web 2.0 most of the explanations and examples have disappeared. That is really a pitty. Is there a plan to extend the documentation? → update: or better, is the documentation elsewhere?

Thanks in advance for your help!

Can you share a sample? I haven’t seen this and don’t know how to reproduce.

If your control is in a container make sure you have enough space below the control to display the popup calendar.

Hello Alberto,
not familiar with the forum yet. hope the image is visible.
Clicking between the double arrows, I get a list of month from “gen” to “dec” but selecting a month will bring me back to the below layout.

Wayne mentiones “controls” and yes, the picker is in a WebPagePanel but I think there is enough space since I see the borders of the Picker.


Hello Wayne,

see my answer to Alberto.
I think there is enough space around the picker since I am able to see the borders of it.

I don’t think that is enough space, maybe that is the problem.

Even stretching the control does not help. It does not touch the borders of the WebPagePanel.
Furthermore I have two lines space below the days. If I point my mouse there, I can see two bars representing two week shown gray and I guess that there should appear the dates for each day of it.


I placed the Picker on a WebPage by its own, but still same result.
We can exclude the space.

So you are saying that a new blank project with just a WebDatePicker on a WebPage has the same problem?

Can you tell us your platform and browser that you are using?
Can you restart Xojo and your computer?

ok, feel free to hit me. I tried with Firefox and it perfectly works.
Before (all the time) I tested with Chrome 86 and 87 and the problem still persists.
OS is Windows 10 with automatic updates enabled, so fairly updated.
Out of curiosity I also checked with MS Edge 87. Works too.

What does this mean now? Am I the only one having a Chrome issue or is something wrong with Chrome -> sounds strange. Should they have a bug since two versions?

Can you clear the Chrome cache? I use Chrome on mac and never seen this problem.

even clearing the cache does not help.
But hey, I have learned that I should test with several browsers :slight_smile:
that is good enough for the moment. I can go on.

Thanks a lot!