webcontainer ENABLED property not working

Dear all

I have a webpage with a webcontainer inside. The container itself is the enhanced TextField object.
When I tried to set the ENABLED property to FALSE, it won’t working.
I tried y turn off the ENABLED property inside Inspector Window side, or via script: myWC.Enabled = False, still I can type inside the webcontainer.

How to set that user cannot type anything at that container?

Env: Xojo 2015 R2.2 with Windows 7 Pro 64 bits

Thanks in advance

You are not very clear.

Do you mean you have a webContainer instance on a page containing a TextField (I do not know what you mean by “enhanced”), or a TextField itself ?

I suspect you have a TextField inside a WebContainer, and instead of setting Enabled for the TextField, you are setting it for the Container.


ContainerControl1.TextField1.Enabled = False or ContainerControl1.TextField1.ReadOnly = True