webcgi or cgi under SSL

I cannot be able to run a standard cgi or webcgi under https. Where’s the issue ?

What have you tried?
Error messages?

With Xojo cloud? Apache Server? Or Windows?

I got a dedicated server Linux Centos 6.6 64bit.
I got a multihost. In the same server I got a wegcgi (32bit) running under http.
In the same server I gat also https domain. I tried to run under a cgi-bin folder both a xojo 32 or 64 bit standard cgi or webcgi.
‘Premature end of script’ is the apache 2 log.
Running the standardc cgi in ssh console I got: ‘Segmentation fault’ error
Running the webcgi in ssh console I got: [quote]Use of uninitialized value $ENV{“REQUEST_METHOD”} in string eq at ./rsaw.cgi line 110.
Can’t use an undefined value as a symbol reference at ./rsaw.cgi line 118.[/quote]

Have you had a look at this?

does the app launch at all on the server?

If you upload it via FTP in ASCII mode, you destroy it!
Or if required libs are not there, it won’t launch.

Ciao Carlo,
maybe you can look at this: https://forum.xojo.com/11882-can-t-use-an-undefined-value-as-a-symbol-reference-in-cgi-file/0/

Bin transfer is anbled on FIlezilla.
I use fcgid so permissions can’t be an issue … also I report another webcgi under port 80 is working.
It is for sure for the webcgi is port number issue…maybe due to a firewall block…
but for standard cgi ? can I set and how a port where to run it ?

I tried to run a console app into my environment (Linux Cents 6.6 64bit).
I got the same erro for the standard cgi prgram:
‘segmentation fault’
Im compiling for linux with latest xojo release 2016 4.1
Runnning with dbg I got this message:

quote run -x=123
Starting program: /var/www/vhosts/api/bin/rsasign -x=123
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x0011b542 in _dl_relocate_object () from /lib/ld-linux.so.2
Do It is a framework bug ?
Please @Greg O’Lone can you give feedback on this issue ?

I can also tell from system log messages:

[quote]Dec 20 18:14:32 cronos kernel: MyApplication.c[6969]: segfault at 4 ip 0088c542 sp bfb0928c error 4 in ld-2.12.so[881000+1e000]
Dec 20 22:14:09 cronos kernel: MyApplication.c[9014]: segfault at 4 ip 00a66542 sp bf935f6c error 4 in ld-2.12.so[a5b000+1e000]
Dec 20 22:32:05 cronos kernel: MyApplication.c[9673]: segfault at 4 ip 00854542 sp bfd36c2c error 4 in ld-2.12.so[849000+1e000]
Dec 20 22:33:00 cronos kernel: MyApplication.c[9714]: segfault at 4 ip 00c7a542 sp bff0439c error 4 in ld-2.12.so[c6f000+1e000]
Dec 20 22:46:30 cronos kernel: MyApplication.c[9882]: segfault at 4 ip 008c4542 sp bfb212ec error 4 in ld-2.12.so[8b9000+1e000]
Dec 20 22:48:11 cronos kernel: MyApplication.c[9893]: segfault at 4 ip 00f67542 sp bfca840c error 4 in ld-2.12.so[f5c000+1e000]
Dec 20 23:46:51 cronos kernel: rsaw[10530]: segfault at 4 ip 00bb9542 sp bfc6dbc c error 4 in ld-2.12.so[bae000+1e000]
Dec 20 23:47:22 cronos kernel: rsaw[10532]: segfault at 4 ip 00706542 sp bf895cd c error 4 in ld-2.12.so[6fb000+1e000]
Dec 21 09:41:55 cronos kernel: MyApplication.c[15739]: segfault at 4 ip 00626542 sp bfb7df4c error 4 in ld-2.12.so[61b000+1e000]
Dec 21 09:42:29 cronos kernel: rsaw[15775]: segfault at 4 ip 00aed542 sp bfa0a8b c error 4 in ld-2.12.so[ae2000+1e000]
Dec 21 09:42:58 cronos kernel: MyApplication.c[15779]: segfault at 4 ip 00e9f542 sp bf7ff2dc error 4 in ld-2.12.so[e94000+1e000]
Dec 21 09:44:16 cronos kernel: rsaw[15784]: segfault at 4 ip 00d7e542 sp bfb2a48 c error 4 in ld-2.12.so[d73000+1e000]
Dec 21 10:42:53 cronos kernel: rsaw[16304]: segfault at 4 ip 001cb542 sp bfcd697 c error 4 in ld-2.12.so[1c0000+1e000]
Dec 21 10:50:29 cronos kernel: MyApplication.c[16388]: segfault at 4 ip 00b98542 sp bf9b096c error 4 in ld-2.12.so[b8d000+1e000]
Dec 21 10:51:14 cronos kernel: rsaw[16397]: segfault at 4 ip 00cce542 sp bf833c7 c error 4 in ld-2.12.so[cc3000+1e000]
Dec 21 10:58:58 cronos kernel: rsaw[16458]: segfault at 4 ip 00e00542 sp bfb69bf c error 4 in ld-2.12.so[df5000+1e000]
Dec 21 10:59:00 cronos kernel: rsaw[16460]: segfault at 4 ip 00bc8542 sp bfbb511 c error 4 in ld-2.12.so[bbd000+1e000]
Dec 21 10:59:02 cronos kernel: rsaw[16462]: segfault at 4 ip 00fea542 sp bf9f92e c error 4 in ld-2.12.so[fdf000+1e000]
Dec 21 11:12:07 cronos kernel: rsaw[16619]: segfault at 4 ip 00f14542 sp bfcfa4f c error 4 in ld-2.12.so[f09000+1e000]
Dec 21 11:13:15 cronos kernel: rsaw[16627]: segfault at 4 ip 009eb542 sp bf8c3d8 c error 4 in ld-2.12.so[9e0000+1e000]
Dec 21 11:13:23 cronos kernel: rsaw[16629]: segfault at 4 ip 00ee7542 sp bfbc678 c error 4 in ld-2.12.so[edc000+1e000]
Dec 21 11:16:06 cronos kernel: rsaw[16722]: segfault at 4 ip 006c3542 sp bfe3e41 c error 4 in ld-2.12.so[6b8000+1e000]
Dec 21 11:16:14 cronos kernel: rsaw[16725]: segfault at 4 ip 00b62542 sp bfb8c06 c error 4 in ld-2.12.so[b57000+1e000]
Dec 21 11:19:16 cronos kernel: MyApplication.c[16740]: segfault at 4 ip 00807542 sp bfd230ec error 4 in ld-2.12.so[7fc000+1e000]
Dec 21 14:55:01 cronos auditd[930]: Audit daemon rotating log files
Dec 21 15:15:01 cronos kernel: rsasign[19018]: segfault at 4 ip 00b95542 sp bfc8 89f4 error 4 in ld-2.12.so[b8a000+1e000]
Dec 21 15:21:20 cronos yum[19093]: Installed: gdb-7.2-90.el6.i686
Dec 21 15:44:12 cronos kernel: rsasign[19281]: segfault at 4 ip 00f5d542 sp bffb dd54 error 4 in ld-2.12.so[f52000+1e000][/quote]

The issue is SSL. But I can’t understand why. THe same webcgi project under non https connection load perfectly…