WebApps Wont Load Compiled Version

I have a WebApp that I originally made in RS.
When I port it over and run, the app works from the debug build just fine but the release version does not. Every time I go to the App it gets hung up on the “Loading…” screen. I pulled the app back over to RS and it works just fine when I build it. I really need my WebApp to work in Xojo as I need to implement the webContainer scroll events which aren’t available in RS. Also I tried to click the Feedback in Xojo to report the issue and I get:

The Feedback API does not understand the method “”. And I can’t log in.

So I can’t even leave feedback on the issue! Nor check if it is a known issue. Does anyone know if this is an issue?

You may not have the current version of Feedback, which is 2.0.0 build 163. Visit https://xojo.com/download/extras.php to download it.

We have a few cross-platform web apps. They all run in the IDE on OS X and when compiled for Windows, OS X and Linux. The only code changes we’ve made from Real Studio to Xojo are for the new SQLiteDatabase class (and related classes) and new NativePath property.

On which OS are you running the IDE?

Examine the code in the Open events of WebApplication, WebSession, WebPage, web controls etc. for things that might have changed with 2013r1. Although it should run on its own if it runs in the IDE, you might have encountered some otherwise hard to discover bug.

I run the IDE in OSX and the debug works fine. I compile for windows and run the app on my server which is where it gets hung up on the loading screen. I don’t want to install Xojo on my server as we really try to limit what goes on the server. It just blows my mind that the debug build works fine and the release build doesn’t…

I tried the release version for OSX and it works fine, so it appears to be a windows version bug. My only option may be to install Xojo on windows and see if I can find where the debugger has an issue.

It is possible to use the remote debugger for this.

Even more curious if I build the application on Windows then the program will work on my Windows server, but if I build for Windows from my Mac the program gets stuck at the “launching…” screen.

This means that Mac and Windows are not compiling the same apps for windows builds which is a very bad thing.

@Brock Nash
Please file a bug report about this ASAP.


I filed a bug report but when I filed it I didn’t completely understand the scope of the issue so the title doesn’t reflect the magnitude. Also I had to make the BUG report private to me and XOJO because I had to include my project which contains highly sensitive information for the company I work for. It is bug #27054.

Should I create a new bug that is public?

Nope. Found it.

I’m assuming I need to wait for the next bug release to build my Web Apps from my iMac then, right? I want to remove my license from my server, but I currently need it on there to build my web apps for windows.

There may be a workaround. Try opening the .cgi and .cfg files in a text editor like BBEdit or Coda and use Save As to save it back onto itself with no changes.

That’s not necessary true (haven’t checked it though). Could it be that the process tries to access the file structure on Windows during startup and the process owner doesn’t have the right permissions?


I’m compiling for StandAlone so I don’t have any CGI files to Save As. I’m curious as to why the standalone executable is created differently when made from the Mac IDE instead of the Windows IDE.

For now build Windows releases from Windows & Mac releases from a Mac.
We’re looking into why this might be as it’s certainly not obvious.

@Norman Palardy ,
Just to clarify this is backwards for me. My Mac build for my Windows Web App doesn’t work. It only works if I build for Windows from Windows. Unfortunately I had to activate my additional license on my Windows Server instead of my home laptop where I would like it.

That’s what I said

[quote=13708:@Norman Palardy]build Windows releases from Windows.
Mac releases from a Mac.