WebApp responsiveness on iOS

I’ve migrated a large webapp with Xojo 2013 R1 FC1.
I was expected for fixes on iOS support.
The 2 mains issues with RS 2012 R2.1 where responsiveness on WebToolbar and WebLabel.
The WebToolbar problem seems to be solved, but the WebLabel is still not responsive and the app is still not useable.
Any ideas on this ?

What do you mean by a WebLabel being “not responsive”? Can you give a feedback # or just describe how to replicate the problem?

@ValryTarondeau
What are you expecting the WebLabel to do?

The responsiveness problem with the WebLabel is on the MouseDown event.

Nobody knows about this ?
I’m about to abandon Xojo for this reason (impossible to make a usable webapp on iPad) :frowning:

Could you provide a small sample project that shows off the problem?

Valry, I fix this specific problem in Studio Stable Web Essentials with the WELabel control:

http://www.studiostable.com/webessentials

In the online demonstration, try the custom “segmented control” which is based on labels, from iOS.

-Brad

@geoff : Thanks for your answer.
Try this link : . It’s fast on a Mac or PC brower (Chrome or Safari) but very slow with iPad and quite unuseable while clicking on buttons with image and label. (These buttons are WebContainers including a WebImageView and a WebLabel)
login : demo@fidelisa.com
password : fidelisa
Sorry, it’s all in french :frowning:

@brad : Thanks. Is it possible to give a try (before buying) your components ?

Could you tell me which buttons specifically? I’m logged into your app via an iPad and the buttons seem responsive but perhaps I’m not tapping on the buttons you are having trouble with.

It’s the Add buttons (the one with “plus” images) for example

Yeah, now I see it. Sometimes it works and sometimes it does not. Can you create a sample project that has that button and the dialog that appears (Ajouter un client)? It doesn’t need to do anything other than display the dialog. Just make sure that you see the same behavior in the sample project as you do in your app.

If you can reproduce it in a sample project, I’ll bet we can fix it.

I too have always had problems with WebLabels and the WebToolbar when using the iPAD. I typically never use the WebToolbar anymore (I build my own as a container of containers) and there are messy javascript tricks you can do to get the weblabels to respond to the mousedown event, but this is something Xojo should definitely have implemented in the framework.

I just took a moment to dig through the events on this page. I see that there’s a WebTimer being fired every second or so. Can you tell me what (if anything) that’s for?

It’s a source code product, so full try, um, that’s not gonna work out too well. But you can try a compiled, running build on our website. As I mentioned above, try on an iPad or iPhone. Notice the responsiveness of the custom segment controls as you touch them. These are built with labels, and specifically work around the bug you’ve noticed.

http://www.studiostable.com/webessentials/demonstration

BTW, this bug reported by me at the end of 2012:

feedback://showreport?report_id=23681

:frowning:

I also use a lot weblabels and my application must run on mobile.

That said, I feel like I have no problem.
But I use MouseUp rather than MouseDown. Can you try with this event?

@greg : The timer is running every 3 seconds. It calls a external http request. This has nothing to do with the responsiveness problem on iOS… it works very well on mac or PC.

The feedback case #23681 posted by Brad is describing perfectly what I encountered.
Is there still a need for a sample project ?

Please remember that just because it works on one browser or platform, it does not guarantee that it will work properly on another. Especially when one uses Touches vs. MouseClicks.

Brad is right though. This bug manifests because we are ignoring the touch events in lieu of the eventual mouseclick event, which Mobile Safari generates ~? second later.

Is your ipad running 6.0.1-6.1.1? This is a known javascript error in all iDevices…works fine on versions below and above or on android :slight_smile: Aside- I finally got webgl running on my ipad (yes)

[quote=15070:@Matthew Combatti]Is your ipad running 6.0.1-6.1.1? This is a known javascript error in all iDevices…works fine on versions below and above or on android :slight_smile: Aside- I finally got webgl running on my ipad (yes)
[/quote]

Actually, it also affects the latest release and beta Chrome on Android. It’s a WebKit behavior.