webapp doesn't start

I have a webapplication that runs fine on a CentOS 6.5
Now I installed a CentOS 6.6 64bit and a CentOS 6.6 32bit, both virtuals on a esxi vmware installation.
On those two installations I get the error:

The permissions are the same as on the first server
I changed the permissions of config.cfg in all ways
I changed owners to apache
I tried everything
I googled like crazy

SO: Is there something missing on the CentOS installation?

are the permissions on all the dirs down to config.cfg the same ?
that’s also relevant

cgi-bin = 755
webestimate = 777

-rw-rw-r–. 1 apache apache 62 Feb 20 18:53 config.cfg
-rwxrwxr-x. 1 apache apache 8658803 Feb 20 18:53 webestimate
-rwxr-xr-x. 1 apache apache 10396 Feb 20 18:53 webestimate.cgi
drwxr-xr-x. 2 apache apache 4096 Feb 20 18:58 webestimateLibs
drwxr-xr-x. 6 apache apache 4096 Feb 20 18:53 Resources

I mean
/var
/var/www
/var/www/cgi-bin
/var/www/cgi-bin/webestimate/
if there are differences on those then you could have issues as well

compare what they are on the 6.5 set up vs 6.6

The only difference is /var/www/cgi-bin/webestimate
which is 777.
I changed it in 755 but no difference.

I still think this has something to do with linux.
There must be a difference/missing in installation.
Some conf file couldn’t be, because they where never touched.

and apache is the user thats running the web server ?

certainly seems to be permissions related but I’ll be darned if I can tell what from here

[quote=169492:@Norman Palardy] /var
/var/www
/var/www/cgi-bin
/var/www/cgi-bin/webestimate/[/quote]
If these are the same as the other installation then check the group and make sure apache is a member of the group that can write to them.

All three installations are standard.
No config files are touched

One is standard for 6.5, two are standard for 6.6.

Just because you have not touched anything doesn’t mean the standard configuration has not changed. I run RHEL here and every point release breaks something. Our certification process between versions is quite painful at times.

So we have some options:

  1. Tomorrow I can install CentOS 6.5 and see what happens
  2. I could compare 6.6 and 6.5 but I don’t know where to start
  3. Or has anyone of you another proposition?

I could also install CentOS 7

Okay. I wait for some propositions and read about it tomorrow.
It is almost midnigth in Belgium now, so I think it is better to have some sleep.

I hope to find some good Ideas tomorrow.
Thanks for your support
Hear from you tomorrow.

Good night
Roland

config.cfg should have 666 permissions

Also, do you have a .htaccess file? If you do, I’d be curious to see the contents.

I finally found the answer.
I installed a CentOS 7 x86_64, basic

yum update

yum groupinstall “basic web server”

/usr/bin/yum -y install glib2.i686 libgcc.i686 libstdc++.i686

systemctl restart httpd.service

apachectl graceful

systemctl enable httpd.service

when the app is launched at this point we will get the answer

after

setenforce 0

systemctl disable selinux

it started

I did not do the following to stop the firewall
systemctl status firewalld
systemctl stop firewalld
systemctl disable firewalld