Web edition does not run under Linux Mint

I just tried to run a web program in the IDE in Xojo under Linux Mint. It seems to compile, but when complete, nothing. On Mac or Windows the default browser opens and the program is launched. Here, nothing. Is this a Linux bug or is there something I should do ?


Not sure about the launching issue, but load a browser manually and access and see if it responds. If it does, just leave that window open. Doesn’t fix the problem per-se, but allows you to continue working until the real problem is figured out.

I tried of course. No luck, page not found :frowning:

Did you include the loop in the main thread to keep it alive? Probably so, but you never know…

Try using ShowUrl in a desktop app and see if that works for you. If not, we may not be able to launch the default browser.

Michel, do you have the Xojo Cloud selected in the Build Settings, here if i turn that off Xojo webapps start the browser just fine. If that option is selected i guess that the IDE first tries to connect to the Xojo cloud.

That’s a bug. Please file a feedback report.

Any chance you’re running Linux Mint in virtual machine with no network interfaces up/configured (no loopback, Had this too last year (LM Olive and Xojo 2013 - not with newer versions).


You are right, I did not notice Xojo Cloud was checked as default. I unchecked it, and now the browser is launched.

This is a bug. I filed a bug report :
33286 - Web apps : Xojo Cloud build should not be checked as default

Thank you for your sagacity :slight_smile:

Thank you all for your suggestions – problem solved now.

I am using a real PC. The problem was elsewhere – see above :slight_smile: