Web application is working/responding very slow on xojo cloud

My web application when deployed on xojo cloud works very slowly. The responses are slow.
Is there a way to increase the speed of web application on xojo cloud?

Do you have a link? I would like to see the performance and compare it to:


This is link to my web application : http://galaxylens.com/GalaxyRemote_Web-Dev/

Your server seems not be very fast, also you are sending pictures of near 5Mb! as “background”. That’s a bad practice shrink it.

For example this: http://galaxylens.com/GalaxyRemote_Web-Dev/index.cgi/711B546CA5303B8D7DC81A6F2EBA8126B4219B81/files/2163-4976-8784-2060-5017/bg2%402x.png

Agreed. the 2x version is too large. Secondly, if you’re not using that timer, I suggest that you remove it. it’s creating lots of unnecessary traffic. If you do need it, consider making the period of the timer longer. 1 second is a bit fast for an app on the web.

Lastly, you have three javascript files which have bad URLs, each of which is requested twice:

Browsers typically have 4 sockets available when first connecting to an app. With these three having bad URLs, the browser has to wait for them to time out which means that there’s actually only 1 socket for downloading your entire app.

I suspect that if you fix these three things, your app will behave much better.

I’ll try this and will let you know

These are required in my project. I have removed the duplication though.
I’m using jquery to mask the textfields to only able to enter numbers in some textfields.
For Dymo js it is required it is used for printing the labels from my application
I have removed the timer.
Is there any alternative way for masking text field so that user can only enter number with decimal and minus sign?

It’s not that you can’t use them, but the urls you have supplied are not valid. If you look at the browser debugger, you can see that it’s a url embedded in a url and it’s badly formed.



I have added this in the HTML Header
Can you please tell me what is wrong with it?
I don’t know much about jquery and javascript.

Just make sure also that the URL’s are valid and respond when they are called.

It may also be that you need an API key to use google API.

They did respond, and was quick
Should I have to use jquery cdn?

@Jos Mara Terry Jimnez, you said the server is not very fast.
I have tried all the ways that you guys suggested, but app is still not responding much fast.
Is it related to the server ?

To be honest, I sense a lot of bad practices.
Your app takes over 5 seconds to load. Something is going horribly wrong.

For example, if I change a page, every image is loaded again. Why? Aren’t you using containers?

My guess is it’s not the server, but can’t say more without you posting the code.

Actually I did not work on it code from the scratch, so don’t know why it is done, there are many web pages.
SO is it because so many web pages?

Please do give me some suggestion which I could use for my code optimization, which can help me improve the speed of my app on xojo cloud

[quote=376636:@devyani gaikwad]@José María Terry Jiménez, you said the server is not very fast.
I have tried all the ways that you guys suggested, but app is still not responding much fast.
Is it related to the server ?[/quote]

Use Network tools from developer’s options (Firefox, Chrome) and see how long takes loading everything.

Thanks. I will try that :slight_smile:

Have you reduced the size of the pictures? This was recommended earlier in the thread, but I did not read any follow-on info. Reducing the size of the pictures will undoubtedly improve the responsiveness of the application.

Yes, I have done that…
Rather than already laoding it in code…I have loaded the image at Run time
I have followed the steps in this link